[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yealink SIP-T22P OpenVPN issue
Author Message
siny Offline
Junior Member
**

Posts: 11
Joined: May 2014
Reputation: 0
Post: #15
RE: Yealink SIP-T22P OpenVPN issue
I have (accidentally) solved the problem:

normally, I use Linux for all of my work, but yesterday tried to unpack client.tar in Windows using 7zip and saw an unexpected directory named "PaxHeaders.2950".

After some searching, found out that my GNU tar 1.26 is by default adding POSIX info to the tar file, so I tried to re/create archive with "-H gnu" and finally was able to successfully upload the file to the phone and see text "vpn.cnf" in the text box after upload (it used to be empty on previous attempts).

Everything worked after reboot, so I am a happy user now.

May I suggest adding this to the official guide?


But now I have another problem: when trying to Autoprovision phone from my TFTP server, I can set all of the parameters except VPN. Relevant part of the "0015xxxxxxxx.cfg" is this:

network.vpn_enable = 1
openvpn.url = http://192.168.11.2/client1.tar

If I put the same lines in "y000000000005.cfg" it downloads the .tar file from server, but does not enable VPN.


Best regards,
Sinisa Bandin

One more suggestion to the developers: I think it would be very good to see the VPN status in the Status screen: IP address, server's address (public and VPN), assigned routes....

Best regards,
Sinisa Bandin
(This post was last modified: 07-11-2014 08:16 PM by siny.)
07-11-2014 08:10 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
Yealink SIP-T22P OpenVPN issue - mahan77 - 03-10-2014, 09:22 PM
RE: Yealink SIP-T22P OpenVPN issue - siny - 05-23-2014, 04:18 PM
RE: Yealink SIP-T22P OpenVPN issue - siny - 05-27-2014, 03:51 AM
RE: Yealink SIP-T22P OpenVPN issue - siny - 05-27-2014, 04:47 PM
RE: Yealink SIP-T22P OpenVPN issue - siny - 06-01-2014, 05:34 AM
RE: Yealink SIP-T22P OpenVPN issue - siny - 07-11-2014 08:10 PM
RE: Yealink SIP-T22P OpenVPN issue - KNERD - 08-07-2014, 04:36 AM
RE: Yealink SIP-T22P OpenVPN issue - siny - 08-10-2014, 03:56 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Yealink C920 password issue DaveK 3 126 09-11-2020 12:02 PM
Last Post: complex1
  Solved Openvpn.tar creating the right size file compsos 3 314 08-20-2020 06:49 AM
Last Post: complex1
  Modern Yealink Phonebook Generation Tool rgranholm 2 1,466 04-30-2020 09:03 PM
Last Post: rgranholm
  Multicast / Paging / Intercom - Yealink T58 Ryandh 20 21,213 04-30-2020 03:23 PM
Last Post: Chris708
  YEALINK AUTO PROVISION Dmitryche 1 1,212 08-09-2019 09:25 AM
Last Post: Paz_Yealink
Question 3CX / Yealink passthrough VLAN issue (when phone is rebooted) maindriver 3 1,516 08-01-2019 12:19 PM
Last Post: Evan_Yealink
  LDAP Directory Configuration Issue it_prevent 1 1,493 05-15-2019 05:55 AM
Last Post: Mike_Yealink
  OpenVPN and QoS/TOS roelvanmeer 0 1,071 02-19-2019 09:27 AM
Last Post: roelvanmeer
  Yealink Dialplan Alain 0 1,447 09-19-2018 05:10 PM
Last Post: Alain
  OpenVPN Timeout connecting p2xt 3 2,790 07-13-2018 07:37 PM
Last Post: jolouis

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication