New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Alert-Info Ringtone not working
Author Message
tima Offline
Junior Member
**

Posts: 18
Joined: Jun 2014
Reputation: 0
Post: #1
Alert-Info Ringtone not working
Hello,

Using T53W or T54W firmware 95.84.0.30 the Alert-info doesn't appear to be working.

Example sip invite, PCAP from the phone confirms this. In account 1 Distinctive Ring Tones set to "yes" in settings > ring, Internal Ringer 1 set to inbound-call and file set to Ring1.wav

Default ringtone under settings > preferances > ringtype set to ring2.wav


@2019-08-01_15:31:21
Sending to 64.246.97.85:5060
INVITE sip:9999@x.x.x.x SIP/2.0
Via: SIP/2.0/UDP y.y.y.y:5060;branch=z9hG4bKSfHHDZ1xL1LYhF0k8D01E6
Call-ID: 20190801193121028329-dc7bb27bfda48f37503dad99af13f4a1
Contact: <sip:y.y.y.y:5060;transport=udp>
CSeq: 201 INVITE
From: "Someone" <sip:1419xxxxxxx@z.z.z.z>;tag=SfHHDZ1xL1LYhF0k8D01E6
Max-Forwards: 60
To: <sip:9999@testdomain.com>
Date: Thu, 01 Aug 2019 19:31:21 GMT
Alert-Info: inbound-call
Content-Type: application/sdp
Content-Length: 345




Inbound call rings ring2.wav not ring1.


Attached File(s) Thumbnail(s)
               
(This post was last modified: 08-01-2019 07:44 PM by tima.)
08-01-2019 07:41 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
complex1 Offline
3CX Adv. Cert. Engineer
*****

Posts: 696
Joined: Jan 2014
Reputation: 22
Post: #2
RE: Alert-Info Ringtone not working
(08-01-2019 07:41 PM)tima Wrote:  Hello,

Using T53W or T54W firmware 95.84.0.30 the Alert-info doesn't appear to be working.

Example sip invite, PCAP from the phone confirms this. In account 1 Distinctive Ring Tones set to "yes" in settings > ring, Internal Ringer 1 set to inbound-call and file set to Ring1.wav

Default ringtone under settings > preferances > ringtype set to ring2.wav


@2019-08-01_15:31:21
Sending to 64.246.97.85:5060
INVITE sip:9999@x.x.x.x SIP/2.0
Via: SIP/2.0/UDP y.y.y.y:5060;branch=z9hG4bKSfHHDZ1xL1LYhF0k8D01E6
Call-ID: 20190801193121028329-dc7bb27bfda48f37503dad99af13f4a1
Contact: <sip:y.y.y.y:5060;transport=udp>
CSeq: 201 INVITE
From: "Someone" <sip:1419xxxxxxx@z.z.z.z>;tag=SfHHDZ1xL1LYhF0k8D01E6
Max-Forwards: 60
To: <sip:9999@testdomain.com>
Date: Thu, 01 Aug 2019 19:31:21 GMT
Alert-Info: inbound-call
Content-Type: application/sdp
Content-Length: 345




Inbound call rings ring2.wav not ring1.

Hi,

I think that the Alert-Info in your SIP Invite example needs to be formulated differently.
I should be something like this:
Alert-Info: <http://www.notused.invalidtld>;info=inbound-call

Best regards,
Frank.

I'm Dutch, not English. Sorry for my imperfect grammar.
08-02-2019 10:55 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
tima Offline
Junior Member
**

Posts: 18
Joined: Jun 2014
Reputation: 0
Post: #3
RE: Alert-Info Ringtone not working
Interesting, looks like the issue is the file naming, the webui indicates (and this worked in V81 and below) using the names as suggested (1-Ring1.wav) but the V83 seems to require you to use just the number to identify the ringtone.

ex:

If I use distinctive_ring_tones.alert_info.1.ringer="1-Ring1.wav" then it fails (used to work) but if I use "distinctive_ring_tones.alert_info.1.ringer="1" then it works fine.

Interesting behavior change.

From Yealink webUI:

CFG Configuration:
distinctive_ring_tones.alert_info.1.ringer
Valid Value:
(1-Ring1.wav;2-Ring2.wav;3-Ring3.wav;4-Ring4.wav;5-Ring5.wav; 6-Ring6.wav;7-Ring7.wav;8-Ring8.wav;9-Silent.wav;10-Splash.wav)
08-05-2019 08:46 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T58A Teams - Call Queues Stopped working Pacxa 9 1,976 09-10-2019 04:06 PM
Last Post: joenathan
  Visual alert for BLF Pickup doesn't work properly Mr_Christian 0 1,058 02-13-2018 10:30 AM
Last Post: Mr_Christian
  Directory Lookups and Smart Dialing Not working Asanka 1 1,665 02-01-2018 09:56 AM
Last Post: Jensen_Yealink

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication