New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Autoprovisionong T4xS v83 error
Author Message
gasper_s Offline
Junior Member
**

Posts: 2
Joined: Oct 2018
Reputation: 0
Post: #1
Autoprovisionong T4xS v83 error
Hello,

does anyone know if there was any change in auto provisioning for firmware version 66.83.x.xx for T4xS phones, because it stops working after upgrading.
I searched documentation and forum, but couldn't find anything.


I have phones T42S, T46S and T48S.

In my y0000000000xx.cfg files I tell them to upgrade firmware:
firmware.url = tftp://172.16.xxx.xxx/T4xS-66.83.0.10.rom

It all worked fine, but after upgrading to 66.83.0.10 it stopped working for all phones.
On phone I get message: "Unable to complete. Will try again now!"
On TFTP server I get message: "TIMEOUT waiting for Ack block #1"

I tried to upgrade to 83.0.10, 83.0.20, 83.0.35 and 84.0.10. It all works from v82, but after upgrade to any of these firmwares, it stops working.

I can still do manual firmware upgrade and downgrade via web browser, but it doesn't work via TFTP autoprovisioning any more.

Does anyone else have this problem?
Any help would be appreciated.


Regards, Gasper
10-30-2018 02:04 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
jolouis Offline
Moderator
*****

Posts: 307
Joined: Oct 2013
Reputation: 5
Post: #2
RE: Autoprovisionong T4xS v83 error
Hi Gasper,

Well I can confirm that upgrading from 66.84.0.10 on a T41S via TFTP works. For testing I added the following line:

firmware.url = tftp://10.168.x.x:69/T41S(T42S)-66.82.0.40.rom

And can confirm the phone rolled back the firmware to 82.0.40 as requested without issue. I did not try with v83 since you said you were still having the issue in 84.0.10 and Yealink always wants tests done with the latest available firmware.

Maybe something strange on your TFTP server?
10-31-2018 02:13 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
gasper_s Offline
Junior Member
**

Posts: 2
Joined: Oct 2018
Reputation: 0
Post: #3
RE: Autoprovisionong T4xS v83 error
Thank you for the hint Jolouis, it is working now.

I'm using TFTPD64 TFTP server and after your message I tried to install same TFTP on a different machine. It also didn't work, so I installed different TFTP server. It worked, so I browsed through parameters. I changed value of the parameter "Negociate" from 1 to 0 and now it seems to be OK, but I'm not sure why. I think it has something to do with the packet size...


BR, Gašper
11-05-2018 10:25 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T32G Auto provisioning error with encryption Mike89 0 1,206 09-18-2017 12:47 AM
Last Post: Mike89
  Upgrade firmware error from tftp boot server guillosur 1 3,066 05-05-2016 06:18 AM
Last Post: Karl_Yealink
  HTTPS/SSL Error nickcoons 18 30,996 02-28-2016 10:17 AM
Last Post: Novum Networks
  Incorrect File Format error on call send, receive or end call morrism 4 6,045 10-06-2015 07:37 AM
Last Post: morrism
  Auto Provisioning error AndyInNYC 1 5,661 09-10-2014 10:19 AM
Last Post: Wilson_Yealink

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication