New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenVPN phones have intermittent audio loss
Author Message
amartin Offline
Junior Member
**

Posts: 4
Joined: Sep 2015
Reputation: 0
Post: #1
OpenVPN phones have intermittent audio loss
Hello,

I have successfully deployed several SIP-T32G, SIP-T38G, and SIP-T42G Yealink phones at remote locations. These phones use the following OpenVPN config to connect to an OpenVPN server running on my Internet gateway and then to an Asterisk server on my LAN. Some of the time, this works very well - calls are clear and both parties can hear each other. However, at other times the call quality will significantly degrade, so that there are intermittent gaps in the audio from one party or both. I have not experienced these same problems with other phones on the LAN, so I suspect the issue lies in the gateway, remote network, or OpenVPN config. Since this is occurring at several different remote locations, I feel that I can probably rule out the remote network as the culprit, which leaves just the gateway or the OpenVPN config on the phones. I am not showing congestion on the gateway, as it is mostly just used for this purpose. I do not see anything obvious in the syslog of one of the phones.

I have done a Wireshark packet capture and and am seeing some jitter (around 10ms average) and delta (around 100ms average) on the packets, but it is hard to exactly correlate this intermittent loss with the audio problems.

OpenVPN client config:
Code:
dev tun
persist-tun
persist-key
cipher DES-CFB
auth SHA1
tls-client
client
resolv-retry infinite
remote <gateway public ip> 1194 udp
ca /phone/config/openvpn/keys/ca.crt
cert /phone/config/openvpn/keys/client1.crt
key /phone/config/openvpn/keys/client1.key
ns-cert-type server

Is wrapping the SIP/RTP traffic inside of an OpenVPN tunnel causing some jitter or latency issues? What else can I do to debugt his prboelm?T
09-10-2015 02:00 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
OpenVPN phones have intermittent audio loss - amartin - 09-10-2015 02:00 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  OpenVPN and QoS/TOS roelvanmeer 0 443 02-19-2019 09:27 AM
Last Post: roelvanmeer
  custom ringtone with new BLF audio alert Chris Barron 0 644 11-26-2018 09:59 AM
Last Post: Chris Barron
  OpenVPN Timeout connecting p2xt 3 1,536 07-13-2018 07:37 PM
Last Post: jolouis
  Yealink T20P phones with Fonality firmware Quan7 0 1,502 10-04-2017 10:00 PM
Last Post: Quan7
  openvpn w52p setup rafael 4 6,950 08-10-2017 02:03 PM
Last Post: indicato
  can't setup openvpn with t48g zzz 8 7,807 07-18-2017 09:04 AM
Last Post: sj
  [SOLVED] T46G one way audio on outgoing calls Kamik 3 4,718 08-16-2016 06:22 PM
Last Post: Kamik
  OpenVPN in T27P arcsistemes 1 2,357 07-13-2016 04:50 PM
Last Post: Klaus_Yealink
  Need to factory reset some T26, T28and T46 IP phones without admin password SupCryp 2 3,682 07-06-2016 06:13 PM
Last Post: SupCryp
  DHCP not working on T26P when OpenVPN is enabled. LandonL 10 11,591 07-03-2016 04:42 AM
Last Post: mfvianna

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication