[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dual-stack mode favouring IPv4 incorrectly
Author Message
Phil2021 Offline
Junior Member
**

Posts: 12
Joined: Jul 2021
Reputation: 1
Post: #1
Question Dual-stack mode favouring IPv4 incorrectly
Hi (no wonder this forum is quiet as messages just get flagged as SPAM by Akismet, not sure how this can be considered SPAM, so its a rubbish system, maybe adding this as extra text works! Edit: Yes adding this text allows it through.)

I've found a bug that means when dual-stack is selected, even though IPv6 is set as preferred, the phone incorrectly favours IPv4 and will not use IPv6.

Firmware version: 77.85.0.25

Setting W60B for IPv6 only, all works correctly and the phone registers using IPv6.

Setting it to IPv4 & IPv6 (so dual stack) and setting preference to IPv6 never results in the registration over IPv6 but it always defaults to IPv4. I can enter the IPv6 address as the SIP server host (rather than the domain) and it will connect via IPv6, so IPv6 is functioning in dual-stack mode. The SIP domain DNS correctly brings back IPv6 addresses, which is why it works under IPv6 single stack but on dual-stack it favours IPv4 addresses over IPv6 addresses and this incorrect when the preference is for IPv6.

I've tried: Disabled and re-enabled the SIP account to see if it then uses IPv6 which it doesn't, this was to rule out that on the reboot the phone was favouring IPv4 as that network simply came up first, this isn't the case.

Many thanks.

So found the answer doing a search in the forum. Someone else fell over this bug in 2017 on a different model, seems some configuration setting needs changing that isn't in the UI.

http://forum.yealink.com/forum/showthrea...light=ipv6

I exported the configuration file, added the setting below, reimported and rebooted and now in dual-stack it favours IPv6.

Code:
account.1.sip_server_mode = 1

Surely 5 years on this should be resolved by now?


Attached File(s) Thumbnail(s)
       
(This post was last modified: 08-01-2021 06:10 PM by Phil2021.)
08-01-2021 05:32 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
Dual-stack mode favouring IPv4 incorrectly - Phil2021 - 08-01-2021 05:32 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  recovery mode W60B files Aleskey 1 1,730 04-09-2022 02:42 AM
Last Post: 88fingerslukee
  Two RT30 doesn't work with W60P in chain mode Keldar 2 5,683 02-28-2019 04:19 PM
Last Post: complex1

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication