New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bad sound with Opus codec on T21 and T40
Author Message
TrK Offline
Junior Member
**

Posts: 4
Joined: Dec 2017
Reputation: 0
Post: #1
Bad sound with Opus codec on T21 and T40
I have several T21P E2 and T40P phones with latest firmware 82.0.20, Asterisk 14 (FreePBX 14 actually, installed with Asterisk 13, upgraded to Asterisk 14 with asterisk-version-switch) and lot of W56 handset (no Opus support yet). I use Asterisk PJSIP driver for my Yealink phones.
Opus was enabled everywhere and also set as primary codec. Asterisk console show calls established using opus (with opus->slin and slin->opus conversion actually).
In phones Opus enabled with autoprovision:
Code:
account.1.codec.opus.enable = 1
account.1.codec.opus.priority = 0
account.1.codec.opus.rtpmap = 107

But voice sound as ... corrupted? Some scratches and crackles, you know.
First I blamed bad network connection, but it was not true - even phones in same LAN have this issue.
I tried to update Opus - download latest codec from Digium and install it to Asterisk. No luck, voice still bad.
I tried to disable Opus in PBX and replace it with G722 - sound become much better!

Should i stay with G722 for now or die trying try to solve this issue somehow?
12-08-2017 10:56 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
Bad sound with Opus codec on T21 and T40 - TrK - 12-08-2017 10:56 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Bad sound with Opus TrK 0 200 12-08-2017 10:53 AM
Last Post: TrK
  Opus Ultra Wideband and Fullband avayax 8 3,435 10-19-2017 06:33 PM
Last Post: Bogen
  Possible to show codec? givemeaccess 3 1,153 06-07-2017 11:24 AM
Last Post: Paul_Yealink
  Opus codec on T23G avayax 1 1,708 10-11-2016 02:55 PM
Last Post: Kevin_Yealink
  BT40 with Voyager Legend CS no sound blackc2004 3 2,802 07-11-2016 03:31 PM
Last Post: kanaille11
  Opus Codec Vanburen 8 4,974 06-14-2016 06:32 AM
Last Post: syadnom
  sound quality of t41 and t48 msafreeport 3 2,146 12-28-2015 12:20 PM
Last Post: Josephbd
  codec g729.. Gilb 0 999 07-25-2015 03:32 PM
Last Post: Gilb
  T42G & T46G Echo and Hollow sound tlsallada 6 12,815 06-22-2015 04:23 PM
Last Post: smb
  T20 click sound when picking up handset Singalong 1 2,271 05-29-2015 06:08 PM
Last Post: Yealink_Elaine

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication