New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] cant get XML to display during startup sequence.
Author Message
cadillackid Offline
Junior Member
**

Posts: 26
Joined: Jan 2015
Reputation: 0
Post: #1
[SOLVED] cant get XML to display during startup sequence.
I have a custom script that I run to configure my new phones to my system. it basically looks for the input of an extension number from the user and then builds the MAC.cfg file based on what is input. the script works great, except that it will not run automatically when a new phone is plugged into the system or one is factory defaulted.

my y000000000028.cfg is as follows
Code:
#!version:1.0.0.1
# action_url.setup_completed = http://172.16.4.2/yealink/newphone.php?user=none
# action_url.ip_change = http://172.16.4.2/yealink/newphone.php
action_url.register_failed = http://172.16.4.2/yealink/newphone.php?user=none
# sip account
account.1.enable = 1
account.1.label = Unregistered
account.1.auth_name = unregistered
account.1.user_name = unregistered
account.1.password = none
account.1.sip_server.1.address = 172.16.4.2
account.1.sip_server.1.expires = 300
account.1.sip_server.1.retry_counts = 0
push_xml.server = 172.16.4.2
features.action_uri_limit_ip = any
#syslog.mode = 1
#syslog.server = 172.16.4.2
#syslog.level = 6
phone_setting.custom_softkey_enable = 1
programablekey.2.type = 27
programablekey.2.value = http://172.16.4.2/yealink/newphone.php?user=none

the script worlks perfectly if it is placed in a softkey or linekey on the phone, but wont display when the phone boots up.

the setup_completed uri would NEVER trigger it..
I then put in a fake SIP account and a trigger on register failed, I can see the script being requested from my web server but it still never displays on the phone screen.

below is the GET from my apache.. it is identical whether automatically called from the register fail or the Softkey.. yet only the softkey one works..
Code:
172.16.4.122 - - [02/Feb/2015:17:06:16 -0500] "GET /yealink/newphone.php?user=none HTTP/1.1" 200 254 "-" "Yealink SIP-T46G 28.72.0.26 00:15:65:76:3d:21"
if I wait for the phone to come up then Manually call the script by pressing my Softkey (as you see I have progammed). the script works perfect. so I know the script is coded right..

is it not possible to display XML to the phone on startup or register fail?

as mentioned above the script is requested from the web server just not displayed. I did not see anything regarding auto provisioning in my syslog and I have set to syslog level 6..

below is the XML being output from the server to the phone. again it works when used with softkey but not from register fail. even though the call makes itto my web server
Code:
<?xml version="1.0" encoding="utf-8"?>
<YealinkIPPhoneInputScreen type = "number" Timeout = "0">
<Title>New Phone</Title>
<Prompt>NewExt:</Prompt>
<URL>http://172.16.4.2/yealink/newphone.php</URL>
<Parameter>user</Parameter>
</YealinkIPPhoneInputScreen>
(This post was last modified: 02-04-2015 06:31 PM by cadillackid.)
02-03-2015 06:09 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
[SOLVED] cant get XML to display during startup sequence. - cadillackid - 02-03-2015 06:09 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] T48S AutoProvisioning ldap.host not used BryanLee 1 822 07-19-2018 03:13 PM
Last Post: BryanLee
  [SOLVED] Modify softkey Wengel 1 2,425 02-21-2017 11:56 AM
Last Post: Wengel
  What's display voice mail in config file avayax 1 2,315 02-21-2017 08:30 AM
Last Post: complex1
  SIP-T20P not provisioning [solved] tonyg@guadagnoconsulting.com 1 3,335 06-29-2016 08:13 PM
Last Post: tonyg@guadagnoconsulting.com
  Softkey Speed-dial display in on-talking cadillackid 3 4,378 12-23-2015 01:30 AM
Last Post: DeepB
Thumbs Up [SOLVED] Auto provision Yealink EXP38 jldalla 1 2,977 09-29-2015 09:06 AM
Last Post: jldalla
  T48G Display Missed Call Popup key for provisioning tomp 5 5,511 12-11-2014 09:06 PM
Last Post: James_Yealink
Question [Solved] T46G: Make remote pronebook emty over provisioning. Kamiware 2 4,128 09-05-2014 03:10 PM
Last Post: Kamiware
  [SOLVED]T41 /T42 Doesn't support autoprovisioning multicast paging line key types. blendedtech 2 4,825 08-20-2014 07:00 PM
Last Post: Yealink Support
  [SOLVED] T46G Codec autoprovisioning issue (V72) Kriss 3 7,024 05-23-2014 11:52 PM
Last Post: nicknomo

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication