New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
W52P Issue with LLDP and VLAN ID
Author Message
derekb Offline
Junior Member
**

Posts: 3
Joined: Jan 2016
Reputation: 0
Post: #1
W52P Issue with LLDP and VLAN ID
Hi Yealink Support,

We’ve installed a number of W52P units at customer location, and are having trouble when trying to set the VLAN ID via LLDP, or even when setting it manually in the Web GUI of the W52P itself.

LLDP is enabled by default on the W52P units. I have a switch setup in our lab where I have 3 Yealink devices – T27P, T46P and W52P. The T27P and T46P get the VLAN ID from LLDP and work correctly. However, the W52P does NOT accept the VLAN ID when sent via LLDP. I have created a Wireshark capture of the W52P booting up while connected to a switch that is advertising VLANID 7 via LLDP.

Also, if I manually set VLAN = Enabled, and set the VLAN ID (7 in my test), this does not work either – the device never obtains DHCP on the VLAN specified.

As a result, we have to have the customer force the switch port to be in the correct VLAN since the device doesn’t function correctly when set to LLDP or when setting the VLAN ID manually.

If I plug the W52P into a network switch with NO LLDP or NO VLAN information, it works perfectly fine.

We’re running a variety of firmwares, but in my example we are running the latest version, 25.73.0.40

Let me know if you need other info

I have sent this request to support.usa@yealink.com -- if you would also like the PCAP, please let me know where to also send it.
05-17-2016 03:16 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
W52P Issue with LLDP and VLAN ID - derekb - 05-17-2016 03:16 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  W52P Dect Interface "Settings" is missing ? CHRIYEA 1 297 06-06-2019 08:58 AM
Last Post: complex1
  W52p Repair Aliaksandr 0 290 04-24-2019 05:41 AM
Last Post: Aliaksandr
  W52P - Detected as Router and Telephone SG300 LLDP jmtread 1 1,907 12-21-2018 12:27 AM
Last Post: jmtread
  W52P admin pass after recovery crodaxy 1 1,027 12-04-2018 10:16 AM
Last Post: complex1
  W52P Handset Registration Fail CSPL 2 1,425 11-28-2018 06:00 AM
Last Post: CSPL
  W52P SfB Fred_ofi 0 701 10-18-2018 02:07 PM
Last Post: Fred_ofi
  W52P handset won't set up kennyb7 0 1,067 06-18-2018 01:01 AM
Last Post: kennyb7
  Configuration Yealink W52P for a GSM Gateway. Yea 2 1,552 05-31-2018 02:45 PM
Last Post: Yea
  W52P Registration Failed TariqPatric 1 2,251 05-09-2018 06:30 AM
Last Post: Jensen_Yealink
  W52P Action URL IPBX 9 4,550 03-03-2018 02:08 AM
Last Post: IPBX

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication