[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED-ish] OpenVPN reconnect
Author Message
mo5 Offline
Junior Member

Posts: 2
Joined: Feb 2014
Reputation: 0
Post: #3
[SOLVED-ish] OpenVPN reconnect
I was able to get it working better with "auth-nocache" and "script-security 2" but not without some caveats.

  1. Dose not to seem clear openvpn 'push "dhcp-option DNS"' if connection is dropped resulting in DNS resolve error on reconnect attempts (using domain for remote), removed option as was unnecessary, openvpn only used for phones. May be related to resolv-retry infinite
  2. Dose not seem to reconnect to openvpn if ethernet cable is reseated, it reconnects to openvpn server, log shows "SIGUSR1[soft,ping-restart] received, client-instance restarting" but dose not restart session, phone has to be power cycled.
  3. Dose work if WAN connection is dropped for some amount of time (tested 5 minute drop out) as long as connection between phone and switch/router is maintained

proto udp
dev tun
remote corp.x.com 1194
ca /yealink/config/openvpn/keys/ca.crt
cert /yealink/config/openvpn/keys/phone1.crt
key /yealink/config/openvpn/keys/phone1.key
dh /yealink/config/openvpn/keys/dh2048.pem
cipher AES-128-CBC
reneg-sec 604800
sndbuf 100000
rcvbuf 100000
verb 5
mute 20
keepalive 10 30
script-security 2
resolv-retry infinite
auth-retry nointeract
ns-cert-type server
(This post was last modified: 02-16-2014 02:33 PM by mo5.)
02-16-2014 02:21 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
[SOLVED-ish] OpenVPN reconnect - mo5 - 02-11-2014, 07:41 AM
RE: OpenVPN reconnect - Yealink Support - 02-12-2014, 04:07 PM
[SOLVED-ish] OpenVPN reconnect - mo5 - 02-16-2014 02:21 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Solved Openvpn.tar creating the right size file compsos 3 1,734 08-20-2020 06:49 AM
Last Post: complex1
  OpenVPN and QoS/TOS roelvanmeer 0 1,528 02-19-2019 09:27 AM
Last Post: roelvanmeer
  OpenVPN Timeout connecting p2xt 3 3,886 07-13-2018 07:37 PM
Last Post: jolouis
  openvpn w52p setup rafael 4 10,742 08-10-2017 02:03 PM
Last Post: indicato
  can't setup openvpn with t48g zzz 8 12,562 07-18-2017 09:04 AM
Last Post: sj
  [SOLVED] T46G one way audio on outgoing calls Kamik 3 7,477 08-16-2016 06:22 PM
Last Post: Kamik
  OpenVPN in T27P arcsistemes 1 3,818 07-13-2016 04:50 PM
Last Post: Klaus_Yealink
  DHCP not working on T26P when OpenVPN is enabled. LandonL 10 16,837 07-03-2016 04:42 AM
Last Post: mfvianna
  T21P : no audio when connect via openvpn kohan 2 4,834 04-16-2016 12:43 AM
Last Post: kohan
  OpenVPN in Yearlink T46G r.schelly 1 4,506 03-19-2016 06:04 AM
Last Post: Yealink_Michael

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication