[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Not showing spanish special characters in the callerid with asterisk
Author Message
arcanos Offline
Junior Member
**

Posts: 5
Joined: Mar 2014
Reputation: 0
Post: #1
Not showing spanish special characters in the callerid with asterisk
Dear friends

I've been trying to fix this, but at the momento I've been uncapable. We are a spanish company that uses Yealink phones with asterisk. Our problem is that if the caller name has an special character (áéíóúñ...), when the call enters in the destination phone, the name doesn't show correctly.

One easy example...

exten => 150,1,Set(CALLERID(name)=María)
same => n,Dial(SIP/usernamefor150,45,two)
same => n,HangUp()

... when you dial 150, in the LCD appears...

Mar?

... instead of...

María

Also happens with realtime extensions or if you define it in sip.conf. Any ideas?

Thanks in advance

Alberto
06-11-2015 11:56 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Flora_Yealink Offline
Senior Member
****

Posts: 265
Joined: Oct 2012
Reputation: 3
Post: #2
RE: Not showing spanish special characters in the callerid with asterisk
Hi Alberto,

Which version you used ?
I tested the latest version 28.73.0.50 on T46, it can work well.
Best Regards!
Flora
06-12-2015 12:16 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
arcanos Offline
Junior Member
**

Posts: 5
Joined: Mar 2014
Reputation: 0
Post: #3
RE: Not showing spanish special characters in the callerid with asterisk
Hi Flora

Mmmm... It's really strange because I've tried with different phone models and firmware versions.

Now I'm testing with a T41P and a 36.73.0.50 firmware version. Same results with a T28P and 2.73.0.50 firmware. Now I don't have a T46 to test.

But doing the exact same test with a Cisco SPA504g works OK. I see "María" in the LCD.

Which version of asterisk are you using? Have you tried the piece of dialplan I posted or are you doing a different test? Do you have any T41P or similar to do the test (T46 is one of the more advanced models, so maybe it has something different)?

Thanks for all

Regards

Alberto
(This post was last modified: 06-12-2015 02:24 PM by arcanos.)
06-12-2015 02:22 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  DND Showing as "Talking" on BLF Key stchelpdesk 1 3,318 06-07-2021 04:45 PM
Last Post: nick9289
  T46s Not showing DND status to other users vgraham 3 5,135 02-24-2021 02:23 PM
Last Post: Albert_Yealink
  Phone book search with accented characters Maxence 0 2,292 11-16-2020 07:18 PM
Last Post: Maxence
  T46S/T46G show green icon (blf) although phones disconnected (Asterisk) jobst 0 2,456 09-16-2020 04:29 AM
Last Post: jobst
  Best practices to notify unconditional call forwarding with Asterisk oliv 1 3,668 08-16-2019 10:07 PM
Last Post: jolouis
  Direct to voicemail transfer with BLF in asterisk - T46G nicknomo 25 86,066 02-02-2019 09:08 AM
Last Post: alexgonzalez
  T48G with newest firmware - Local Directory not showing, Netzwork Directory instead sani390 2 5,343 08-21-2018 03:18 PM
Last Post: johnkiniston
  Group Call Pick Up showing original extension number stratos 1 4,808 07-31-2018 12:49 PM
Last Post: East_Yealink
  BLF showing TALKING issue stratos 0 3,438 05-24-2018 10:52 AM
Last Post: stratos
  T42G: BLF visual alert not showing callee name from LDAP phonebook Lasse 5 10,911 12-11-2017 11:21 AM
Last Post: Lasse

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication