[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SIP-T21P - No audio if SRTP used, also, and no spanish web UI
Author Message
jcvh Offline
Junior Member
**

Posts: 13
Joined: Nov 2013
Reputation: 0
Post: #1
SIP-T21P - No audio if SRTP used, also, and no spanish web UI
Hello everybody!

Recently, our local provider announced it will no longer distribute SIP-T20P phones, but now will sell SIP-T21P.

I have one now, and i am testing its capabilities, so it can be used in our deployments.

So far, i have stumbled into two issues, first, the less important:

1.- No Spanish Web GUI:
I just copied the T20P working template, wich have:

lang.gui = Spanish
lang.wui = Spanish

The web UI doesn´t seem to have a spanish translation, so it gets set into Chinese. Is there any chance that the spanish translation would be included in the future?

Now the important:
2.- No Audio if SRTP is used:
I can get it to register, and everything works fine when the transport used is UDP. I even can set the transport to TLS, and it registers fine, but as long as i try to use SRTP, it kind of loses its audio.
- The calls are completed, but there is no audio in any way
(i am behind several NATs, but i have a T26P with the exact same config working just fine). A packet capture shows no SRTP packets coming out from the phone.
- When i dial, the phone dont even give me ring back tone, it simply goes mute, probably because the RBT comes in band.
- While making outgoing calls (from the T21P), it simply doesn't have audio, if i try a call towards the T21P, the first time it rings OK, but if answered, besides not having audio, after hangup,
the phone don't even give me dial tone when off-hook anymore, not in the handset, nor throu speaker if the speaker or line button pressed. Even more, it DOESN'T RINGS anymore. It kind of loses all audio capacities, and stays like this, even after disabling SRTP. It only normalizes if power cycled, but the no in call audio issue persists.

Besides all that, i noted that aparently there is no configuration for the LAN port mode in the web UI, nor in the phone itself. I read somewhere that the new default is to be set as "router", wich is of no use for our deployments. I sucessfully used the autoprovisioning files to set it in bridge mode. Is weird not having access to that settings in any other way, tho.

Well, i'll be waiting for any comments, thanks in advance, and regards!

JuanV
09-24-2014 03:29 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
James_Yealink Offline
Administrator
*******

Posts: 1,159
Joined: Aug 2014
Reputation: 8
Post: #2
RE: SIP-T21P - No audio if SRTP used, also, and no spanish web UI
Hi JuanV,

What's the firmware of your T21?
Please upgrade to latest 34.72.0.75 and chcek again.

http://www.yealink.com/Upload/UCOne/2014...2.0.75.zip

1.The firmware should contain Spanish.
2.If the SRTP no voice problem still occurs in this firmware, please get a pcap trace/ level 6 syslog/ config.bin file.

http://forum.yealink.com/forum/showthread.php?tid=1319

3.In last firmware the Router mode has been removed in all Yealink model because almost no users will use this mode. The default port mode is Bridge.

Regards,
James
09-24-2014 09:54 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
jcvh Offline
Junior Member
**

Posts: 13
Joined: Nov 2013
Reputation: 0
Post: #3
RE: SIP-T21P - No audio if SRTP used, also, and no spanish web UI
Thank you James for your quick response, my comments:

(09-24-2014 09:54 AM)Yealink_James Wrote:  Hi JuanV,

What's the firmware of your T21?
Please upgrade to latest 34.72.0.75 and chcek again.

http://www.yealink.com/Upload/UCOne/2014...2.0.75.zip

Sorry, i should have said this:
The first thing i did, even before loading any configuration, was upgrade the firmware to the latest version available in de yealink web page, being the exact same you say, 34.72.0.75 .-

(09-24-2014 09:54 AM)Yealink_James Wrote:  1.The firmware should contain Spanish.

I can confirm that the telephone user interface has spanish, this is, the telephone's screen display and menus, but the Web User Interface does not.

(09-24-2014 09:54 AM)Yealink_James Wrote:  2.If the SRTP no voice problem still occurs in this firmware, please get a pcap trace/ level 6 syslog/ config.bin file.

http://forum.yealink.com/forum/showthread.php?tid=1319

I'll provide those as soon as posible.

(09-24-2014 09:54 AM)Yealink_James Wrote:  3.In last firmware the Router mode has been removed in all Yealink model because almost no users will use this mode. The default port mode is Bridge.

In this document:
http://www.yealink.com/Upload/UCOne/2014...n72%20.pdf
Item 3.1 (line 35. first item under "Bug Fixes") reads: "1. Modified the PC Port Configuration of T20/T22/T26/T28 to Router mode by default."

By the way, i need to make you notice that, while using SRTP, once a call is sent to the phone, it looses ALL AUDIO CAPABILITIES, it does "ring": the line button blink, and the incomming call info shows in the screen, that is, but it does not make any noise.

Besides, i noticed that my hardware version is "34.1.0.0.0.0.0", thas doesn't fit in the usual nomenclature, is this normal?

Thanks again!

Regards!

JuanV
(This post was last modified: 09-25-2014 05:10 AM by jcvh.)
09-25-2014 04:07 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
cst_soporte Offline
Junior Member
**

Posts: 1
Joined: Oct 2015
Reputation: 0
Post: #4
RE: SIP-T21P - No audio if SRTP used, also, and no spanish web UI
Hello all

¿Has been solved the issue?. I have the same problem with 80 T21s.

Please, Let us know about the solution.

Thanks.

JALM
10-08-2015 05:07 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T21P Low headset volume rmatuda 14 33,008 11-02-2021 08:39 PM
Last Post: overlay
  Firmware upgrade fails on T21P E2 p.pasquino@technology4you.it 0 1,498 11-02-2021 04:42 PM
Last Post: p.pasquino@technology4you.it
  T21P Stuck on "Initializing" - Recovery Mode Fails` YCMJamie 5 6,061 08-24-2021 07:04 PM
Last Post: YCMJamie
  Lost my configuration trying to fix a static audio problem nestman 0 2,238 06-22-2021 06:33 AM
Last Post: nestman
  T21P E2 default Programmable Key label in V84 erictam 6 10,853 10-28-2020 10:32 PM
Last Post: GwenH
  Recovery files T21P agalindo 1 6,117 06-16-2020 01:49 PM
Last Post: complex1
  T21P Register Failed agatospk 6 11,884 01-31-2020 06:08 AM
Last Post: agatospk
  T21P recover files davidpablo 8 21,970 01-30-2020 02:02 PM
Last Post: Yisroel_MongoTEL
  Low volume yealink T21p miesvictor 2 5,527 12-05-2019 11:35 PM
Last Post: miesvictor
  T21P E2: Missed calls: How to show caller's number? quazgar 1 5,464 12-05-2019 07:19 AM
Last Post: Walter_Yealink

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication