[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T4xG no OpenVPN IP when using TAP
Author Message
Output101 Offline
Junior Member
**

Posts: 2
Joined: Sep 2016
Reputation: 0
Post: #1
T4xG no OpenVPN IP when using TAP
I have a T48G and I have setup an OpenVPN server using TAP. My device will connect (I see a white VPN symbol) however I do not see a TAP adapter (thus no IP) in my device log. When I use TUN, I am able to see an adapter with IP. Note: I tested with a Windows box and will confirm my server has been setup properly.

My WAN IP is 192.168.0.133 and I'm connecting to 192.168.0.190 (test environment for those who notice both are a 'local' addresses). I expect a 10.x.x.x address on my remote network.

Why is my phone not getting an IP (or why do I not see an IP)?

Here is part of my log:
Code:
Aug 31 18:00:03 openvpn[748]: [pfsense] Peer Connection Initiated with 192.168.0.133:1194
Aug 31 18:00:05 openvpn[748]: TUN/TAP device tap0 opened
Aug 31 18:00:05 openvpn[748]: NOTE: unable to redirect default gateway -- VPN gateway parameter (--route-gateway or --ifconfig) is missing
Aug 31 18:00:05 openvpn[748]: Initialization Sequence Completed
Aug 31 18:00:05 openvpn[748]: Link success --init.c, 1138----
eth0      Link encap:Ethernet  HWaddr 00:15:65:9C:68:6C  
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::215:65ff:fe9c:686c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5355 errors:0 dropped:0 overruns:0 frame:0
          TX packets:283 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1024
          RX bytes:1061157 (1.0 MiB)  TX bytes:149980 (146.4 KiB)
          Interrupt:8

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

  PID USER       VSZ STAT COMMAND
    1 root      2064 S    init                
    2 root         0 SW<  [kthreadd]
    3 root         0 SW<  [ksoftirqd/0]
(This post was last modified: 09-01-2016 02:27 AM by Output101.)
09-01-2016 02:25 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Output101 Offline
Junior Member
**

Posts: 2
Joined: Sep 2016
Reputation: 0
Post: #2
Question RE: T4xG no OpenVPN IP when using TAP
Even if I don't force all traffic to go through the gateway, the tap0 device says it is open but never appears.

Code:
Aug 31 20:20:38 openvpn[747]: IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Aug 31 20:20:38 openvpn[747]: NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Aug 31 20:20:38 openvpn[747]: Re-using SSL/TLS context
Aug 31 20:20:38 openvpn[747]: LZO compression initialized
Aug 31 20:20:38 openvpn[747]: UDPv4 link local (bound): [undef]:1194
Aug 31 20:20:38 openvpn[747]: UDPv4 link remote: 192.168.0.133:1194
Aug 31 20:20:40 openvpn[747]: [pfsense] Peer Connection Initiated with 192.168.0.133:1194
Aug 31 20:20:41 ATP [522]: ATP <3+error > Call fail
Aug 31 20:20:42 openvpn[747]: TUN/TAP device tap0 opened
Aug 31 20:20:42 openvpn[747]: Initialization Sequence Completed
Aug 31 20:20:42 openvpn[747]: Link success --init.c, 1138----
...
Code:
Aug 31 20:21:11 ATP [522]: ATP <3+error > http to file failed, code = -3, msg = Connect Failed, retry = 3
eth0      Link encap:Ethernet  HWaddr 00:15:65:9C:68:6C  
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::215:65ff:fe9c:686c/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1903 errors:0 dropped:0 overruns:0 frame:0
          TX packets:201 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1024
          RX bytes:340629 (332.6 KiB)  TX bytes:85871 (83.8 KiB)
          Interrupt:8

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

  PID USER       VSZ STAT COMMAND
    1 root      2064 S    init
(This post was last modified: 09-01-2016 04:11 AM by Output101.)
09-01-2016 04:10 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
gordon0193 Offline
Junior Member
**

Posts: 1
Joined: Mar 2020
Reputation: 0
Post: #3
RE: T4xG no OpenVPN IP when using TAP
This still seems to be an issue as I'm on FW 28.83.0.120 and my T46G never created a TAP adapter in the log files. Change it to a TUN connection and it works and can be seen in the log files.

Thanks,
04-11-2020 08:16 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T41P and OpenVPN coltarushalo 0 1,126 05-26-2021 02:58 AM
Last Post: coltarushalo
  Packet Capture - T4x w/OpenVPN coltarushalo 0 1,124 03-13-2021 01:15 AM
Last Post: coltarushalo
  OpenVPN issue with SIP/UDP fredoch 0 1,609 11-10-2020 03:47 PM
Last Post: fredoch
  OpenVPN Version List coltarushalo 0 1,452 08-03-2020 08:35 PM
Last Post: coltarushalo
  [SOLVED] OpenVPN not doing anything T42G V83 Danariel 5 8,721 03-27-2020 02:32 PM
Last Post: jamesg224
  OpenVPN not working on T46S 66.83.0.35 _DJ 3 6,166 05-11-2019 07:54 AM
Last Post: complex1
  What cipher will T46G support in OpenVPN AndyInNJ 1 3,730 02-07-2019 01:32 PM
Last Post: jolouis
  OpenVPN tunnel disconnects frequently Ozy 2 3,959 11-01-2018 08:09 PM
Last Post: dannylarsen
  SHA256 for OpenVPN maibua 0 2,411 07-23-2018 08:11 AM
Last Post: maibua
  T4xG series having time issues KNERD 4 7,500 04-20-2018 08:51 PM
Last Post: KNERD

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication