[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DNS-SRV Record lookup fails -- *Solved*
Author Message
Bryan Nelson Offline
Member
***

Posts: 71
Joined: Feb 2013
Reputation: 0
Post: #1
Question DNS-SRV Record lookup fails -- *Solved*
I am currently testing the new T-46g model, and am having an issue with the SRV records that our system uses. T-2x models do not have a problem with the same address. It appears that it is only attempting an a-record lookup on the address, and not the full NAPTR\SRV lookup.

Registering via UDP with our a-record works fine, and I really do like this new model!

; <<>> DiG 9.9.2-P1 <<>> _sip._udp.********.*******.com SRV
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 51495
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;_sip._udp.********.*******.com. IN SRV

;; ANSWER SECTION:
_sip._udp.********.*******.com. 300 IN SRV 100 10 5060 ********.*******.com.
_sip._udp.********.*******.com. 300 IN SRV 10 10 5060 ********.*******.com.

;; Query time: 64 msec
;; SERVER: 127.0.1.1#53(127.0.1.1)
;; WHEN: Thu Jul 11 13:36:18 2013
;; MSG SIZE rcvd: 160
-------------------------------------
Jul 11 18:59:34 SIP [384]: SUA <5+notice>[000] host=[********.*******.com], transport=[3], port=[5060], family=[2]
Jul 11 18:59:34 SIP [384]: DNS <5+notice>[DNS] ********.*******.com is not found in dns cache
Jul 11 18:59:34 SIP [384]: DNS <5+notice>[DNS] set DNS timeout: [3000], tries: [2]
Jul 11 18:59:34 SIP [384]: DNS <5+notice>[DNS] About to query [********.*******.com] IN A/AAAA
Jul 11 18:59:34 SIP [384]: DNS <3+error >[DNS] query error: [DNS server returned answer with no data]
Jul 11 18:59:34 SIP [384]: SUA <5+notice>[000] DNS query : DNS query error

I have "solved" this issue after reading the admin guide a little closer. The behavior is a little different than previous models, which may cause some confusion.

"If a port is set to 0 and the transport type is set to DNS-NAPTR, NAPTR and SRV queries will be tried before falling back to A queries. If no port is found through the DNS query, 5060 will be used. If an explicit port (except 0) is specified and the transport type is set to DNS-NAPTR, the only lookup will be an A query"

*edit -- Redacted server addresses due to attempted access.

In previous models(even the similar T-38), SRV records would still be attempted when the port is set to the default of 5060. On the T-46, you must manually set the port to "0" if you wish to use SRV. Ideally, this behavior would be matched to the older phone models, for consistency. Otherwise, it may be a good idea to set the default port to "0" when setting the transport to NAPTR\SRV, as it doesn't make much sense for the default setting to automatically disable the transport you select. Wink
(This post was last modified: 07-12-2013 09:26 AM by Bryan Nelson.)
07-12-2013 03:41 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
DNS-SRV Record lookup fails -- *Solved* - Bryan Nelson - 07-12-2013 03:41 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [SOLVED] OpenVPN not doing anything T42G V83 Danariel 5 10,732 03-27-2020 02:32 PM
Last Post: jamesg224
  T42S - Show sip from + remote xml caller id lookup OneDirectSpain 0 2,213 10-30-2019 03:54 PM
Last Post: OneDirectSpain
  T41S recovery from TFTP fails jwhopkins 3 7,559 07-25-2019 01:19 AM
Last Post: Baron_Yealink
  T48G Registers Successfully, Then Later Fails blackoil 2 4,103 04-10-2019 09:48 PM
Last Post: blackoil
  Solved - T46G - Firmware issues - 28.83.0.50 B-C 1 6,109 10-13-2018 09:33 AM
Last Post: complex1
  [T48] - NTP time update fails DennisT 0 3,147 07-17-2018 05:45 PM
Last Post: DennisT
  T48G Webrequest Time Outs? Solved Attila 0 2,829 07-07-2018 06:41 AM
Last Post: Attila
  [Solved] Power LED indicator in power-saving mode complex1 13 19,602 04-29-2018 05:05 PM
Last Post: complex1
  DND is not working - T46G phone rings anyway (SOLVED) Dirk999 2 5,640 03-23-2018 03:15 PM
Last Post: Dirk999
  [T46G] Action URI problem (SOLVED) ERWIN 3 7,581 03-16-2018 02:42 PM
Last Post: ERWIN

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication