[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SOLVED - T46G OPENVPN
Author Message
briankelly63 Offline
Member
***

Posts: 55
Joined: Jul 2013
Reputation: 1
Post: #1
SOLVED - T46G OPENVPN
Update:
The key to this issue is the paths used in the vpn.cnf file. You may get a successful upload but unless you accurately reference the location of the files things are not going to work and an examination of the phones log will indicate that it can't find the files. The previous T28 or early t38 path format will not work!

The correct paths for the T4XG are:

ca /config/openvpn/keys/ca.crt
cert /config/openvpn/keys/client.crt
key /config/openvpn/keys/client.key

The exportable T38G (2) style client.tar files in the Pfsense OPENVPN package match what is needed for the T4XG.
Also key to getting RTP audio to work is by adding your VPN subnet to the localnet entry in Asterisk.

Example localnet=192.168.2.0/255.255.255.0

Read up on multiple localnet entries in SIP config.

You may find this Yealink guide helpful except for the path information:

ftp://ailsa:6br6pcyl@ftp.yealink.com/OPEN-VPN.rar

------------------------------------------------

Is the OPENVPN tar file structure on the T46G the same as the 38? 28? Any OPENVPN docs specific to the T46G available? I already have the existing Yealink OPENVPN doc which is now a bit out of date and does not address the T4X series.

Update: The phones log indicates that it can't find the clients1.crt file which I've specified (including path) even though it is in the uploaded tar file which is in the proper format. The tar file is accepted during the upload.

So this may be a path issue, unique to the T46G that Yealink needs to clarify. The crt file is being placed somewhere in the phone file system the question is where.

I did notice a /factory/openvpn directory in the log files but that didn't seem to be it.
(This post was last modified: 07-08-2013 02:19 AM by briankelly63.)
07-04-2013 06:43 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
SOLVED - T46G OPENVPN - briankelly63 - 07-04-2013 06:43 AM
RE: T46G OPENVPN - Yealink Support - 07-05-2013, 02:36 PM
RE: T46G OPENVPN - briankelly63 - 07-05-2013, 07:35 PM
RE: SOLVED - T46G OPENVPN - grooveion - 11-02-2013, 06:24 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Passing only LDAP traffic through OPENVPN Commensus 0 1,097 02-23-2022 09:47 PM
Last Post: Commensus
  Configuring OPENVPN with Yealink Commensus 0 1,258 02-23-2022 09:45 PM
Last Post: Commensus
  DHCP not working on T26P when OpenVPN is enabled. LandonL 11 30,603 05-12-2021 10:46 AM
Last Post: 1sae
  Solved Openvpn.tar creating the right size file compsos 3 6,204 08-20-2020 06:49 AM
Last Post: complex1
  OpenVPN and QoS/TOS roelvanmeer 0 3,716 02-19-2019 09:27 AM
Last Post: roelvanmeer
  Change standard outgoing line on T46G oestersund 1 5,186 12-15-2018 09:58 PM
Last Post: support2
  OpenVPN Timeout connecting p2xt 3 8,167 07-13-2018 07:37 PM
Last Post: jolouis
Bug T46g & T48G RADIUS 802.1x and SHA256 Bigmac 22 47,035 08-13-2017 07:54 PM
Last Post: MiKeDaDoC
  openvpn w52p setup rafael 4 16,464 08-10-2017 02:03 PM
Last Post: indicato
  can't setup openvpn with t48g zzz 8 20,382 07-18-2017 09:04 AM
Last Post: sj

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication