[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB Upgrade issues
Author Message
complex1 Offline
3CX Adv. Cert. Engineer

Posts: 1,283
Joined: Jan 2014
Reputation: 38
Post: #2
RE: USB Upgrade issues
(07-20-2021 11:14 PM)acwells Wrote:  Hi, I am trying to recover a couple of T58 SIP phones and I have the BIN, RFS, and ROM files on USB. I boot the phone with the USB installed in the back while pressing the speaker button and I get Usb failed (-4)

Is it looking for a specific format of USB stick? I am currently formatted FAT32

Also tried renaming the files T58, T58A, T58V but nothing seems to help.

Any ideas?


Please try this:
Rename the files to T58.bin, T58.rfs and T58.rom, insert the USB stick in the phone USB port, press and hold the Redial button, connect power and then press 2 when prompted for USB.

Hope this will help.

Kind regards,

I am not an employee of Yealink.
Dutch is my native language, not English. Apologies for my imperfect grammar.
Please do not send unsolicited PM messages. I will not answer them.
07-21-2021 01:55 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
USB Upgrade issues - acwells - 07-20-2021, 11:14 PM
RE: USB Upgrade issues - complex1 - 07-21-2021 01:55 AM
RE: USB Upgrade issues - acwells - 07-21-2021, 03:42 AM
RE: USB Upgrade issues - acwells - 07-21-2021, 10:02 PM
RE: USB Upgrade issues - complex1 - 07-21-2021, 11:14 PM
RE: USB Upgrade issues - Your Voice - 08-25-2021, 10:51 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  After YDMP upgrade Sub-accounts can't login JohnMc 0 49 08-11-2022 03:47 AM
Last Post: JohnMc
  VP59 Upgrade to Teams Edition mamboz 1 3,787 12-16-2020 05:35 AM
Last Post: Yisroel_MongoTEL
  upgrade EHS36 and EXP40 rpenrod 12 26,890 09-03-2020 08:35 PM
Last Post: acqup001
  VP59 - Teams-to-Teams Federated User issues darwin.ranzone@originnet.com 0 2,893 07-23-2020 04:41 PM
Last Post: darwin.ranzone@originnet.com
  Firmware upgrade error on T23G acubino 1 5,085 07-22-2019 03:03 AM
Last Post: Evan_Yealink
  Wrong Password after fimrware upgrade Dario 3 7,751 06-03-2019 03:23 PM
Last Post: complex1
  T27G - Fall Back issues - Successive setting [Solved] BobBluePackets 6 10,610 05-28-2019 04:47 AM
Last Post: BobBluePackets
Exclamation Yealink Device Management issues Jonathan_01023 2 6,532 06-07-2018 01:24 AM
Last Post: Karl_Yealink
  upgrade EXP40 Remko Schenk 1 5,416 03-13-2018 03:42 AM
Last Post: Eavin_Yealink
  Random Registration issues joshua@itstel.com 1 6,073 10-12-2017 10:49 AM
Last Post: Travis_Yealink

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication