[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T46s won't try to register to server on local subnet
Author Message
jigjag Offline
Junior Member
**

Posts: 2
Joined: Apr 2020
Reputation: 0
Post: #1
T46s won't try to register to server on local subnet
I have a Yealink T46s running v85.05 firmware with static IP 172.16.0.11 and DNS 8.8.8.8. The phone server 172.16.0.5 is in the same subnet 172.16.0.0/23 (literally on the same switch). I won't detail what type of phone server because its not even receiving packets from the Yealink phone, so the issue is on phone side.

Using the webpage of the phone / Settings / Configuration / Pcap, start

and configure phone like:
(Register Name, Username and Password are set as appropriate)
account.1.sip_server.1.address=172.16.0.5
account.1.sip_server.1.port=5060
account.1.sip_server.1.transport_type=1 (tcp)
account.1.sip_server.2.address=sip2.example.com
account.1.sip_server.2.port=5060
account.1.sip_server.2.transport_type=1 (tcp)

The registration to sip2.example.com works, but 172.16.0.5 fails.
I stop the pcap and see that the phone does have register traffic to sip2.example.com, but no packets, NONE AT ALL, are sent to 172.16.0.5.

When I export the log with Settings / Configuration / Export Local Log
(which by the way exports a zip file that's really a tar, confusing window's built in unzip program)

Anyways, the log shows the following messages over and over again:
<131>Sep 8 11:50:22 WEB [911:921]: WEB <3+error > 622.372.946:Send msg : [DONOW:NULL] [app_vpPhone], 0x60d02, 0, 0, , 5000
<131>Sep 8 11:50:22 WEB [911:921]: WEB <3+error > 622.373.614:CallDskMsgTimeoutEx [0x60d02] lret[2]
<131>Sep 8 11:51:05 sua [579.650]: NET <3+error > [255] close err socket=19!
<131>Sep 8 11:51:05 sua [579.650]: DLG <3+error > [255] out_socket is 0
<131>Sep 8 11:51:05 sua [579.650]: DLG <3+error > [000] <AEM> code=0x04030000, cb_transport_error (id=58), target=172.16.0.5:5060

I checked to make sure the phone can reach the phone server... Network / Diagnostics / Ping 172.16.0.5
# ping 172.16.0.5
PING 172.16.0.5 (172.16.0.5): 56 data bytes
64 bytes from 172.16.0.5: seq=0 ttl=64 time=0.484 ms
64 bytes from 172.16.0.5: seq=1 ttl=64 time=0.323 ms
64 bytes from 172.16.0.5: seq=2 ttl=64 time=0.336 ms
64 bytes from 172.16.0.5: seq=3 ttl=64 time=0.333 ms

--- 172.16.0.5 ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 0.323/0.369/0.484 ms

I also double-checked that certificate checking was disabled at
Security / Trusted Certificates /
- Only Accept Trusted Certificates: Disabled
- Common Name Validation: Disabled
- CA Certificates: All Certificates

I even tried only having account.1.sip_server.1.address as sip1b.example.com (pointing to 172.16.0.5) and the phone still refused to sending a single packet.

If I switch the transport_mode to 0 (udp) it DOES send packets, but I don't want my phone server to allow UDP packets. Eventually I want to set up TLS/SRTP, so don't want to depent on UDP.

I really need to register to both servers. The first one is intentionally kept within the subnet to be resilient against DNS failure. The second server is in the cloud to allow remote users to reach a server if the primary goes down.

Any suggestions? or anyone know if this is a firmware bug?
09-08-2020 10:52 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
T46s won't try to register to server on local subnet - jigjag - 09-08-2020 10:52 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  What is alarm server alarm.server.address ? (W59R) Ivan86 0 363 08-10-2021 04:42 PM
Last Post: Ivan86
  LDAP server is unavailable Andrei9385 2 4,003 07-16-2021 08:34 PM
Last Post: nolto
  T46s/T48s - Serial Number @Webinterface Bernhard77 2 1,703 01-29-2021 04:10 PM
Last Post: Bernhard77
  Fast REGISTER failover? IgorG 0 1,009 10-13-2020 04:20 AM
Last Post: IgorG
  Register Requests TeleMax 1 1,651 10-01-2020 04:09 PM
Last Post: Yisroel_MongoTEL
  T46S Firmware 66.83.x.x Chris708 6 6,064 05-14-2020 01:42 PM
Last Post: Chris708
  .cfg file needed for Zultys provisioning server jerryp 0 1,686 01-30-2020 09:26 PM
Last Post: jerryp
  Register to the multi tenant PBX (where is right forum to post?) steve.newton 1 2,318 01-15-2020 11:59 AM
Last Post: Garry_Yealink
  Yealink Phone to Send Private IP Address on Register Ari 4 4,996 10-23-2019 10:04 PM
Last Post: Ari
  Yealink T46s Park button mhessels 8 10,712 01-31-2019 02:24 AM
Last Post: BobBluePackets

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication