[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Thread Closed 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
leading '1' is stripped off number in History
Author Message
jakthree Offline
Junior Member

Posts: 3
Joined: Oct 2019
Reputation: 0
Post: #3
RE: leading '1' is stripped off number in History
(08-08-2020 04:18 PM)complex1 Wrote:  
(08-07-2020 07:48 PM)jakthree Wrote:  Hi,

My problem is when I attempt to dial a call from history that came from an external or internal number that starts with ‘1’, the dial (send) will fail because the ‘1’ is stripped off. The problem occurs on T27G and T46S phones.
I receive an external call from 12223334444 (or internal extension 1044).
The number shows up in History as 2223334444 (or 044).
When I select the number and press send, the call will fail because of the missing ‘1’.

I have confirmed by packet capture that the full number is sent to the phone.

Is there a parameter in the phone that strips off the leading '1'?
If yes, which parameter and how do I change it to leave the phone number as is?

If no, then how to proceed to find out where the '1' is being stripped?

Thank you,


Have you already reset the phone to factory settings and checked if the issue is solved?

Hope this will help.

I found that 3CX was stripping the '1' off in the leg between 3CX and the phone, because of two reasons. First was the 'country' rule and second was due to a known issue with routing calls throught a 3CX bridge between sites. I worked around the issue by setting up two outbound rules that append a '1' to 3-digit and 10-digit numbers. So far so good.
You can mark this a solved.
Thank you,
(This post was last modified: 08-10-2020 10:59 PM by jakthree.)
08-10-2020 10:58 PM
Find all posts by this user    like0    dislike0
Thread Closed 

Messages In This Thread
RE: leading '1' is stripped off number in History - jakthree - 08-10-2020 10:58 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Ability to bypass number pad on T48 screen? celito 8 10,251 05-22-2020 03:08 PM
Last Post: cwatts@deltamodtech.com
  T41S units asking for last 5 digits of serial number then reseting to factory richard.vince 1 4,053 04-08-2020 08:16 AM
Last Post: complex1
  T46S: Outlook contacts are called to email instead of telephone number primator 0 1,941 02-14-2020 12:24 PM
Last Post: primator
  Call History Export (T46S) michael_e 1 2,843 02-03-2020 07:56 PM
Last Post: complex1
  Skype for Business contact called by e-mail and not phone number primator 0 1,663 09-10-2019 02:08 PM
Last Post: primator
  T46S - call forward target (number) on display mikedonn 2 5,863 07-15-2019 02:43 PM
Last Post: mikedonn
  LDAP (MS AD) T48G only displays single number scubes 1 2,705 05-14-2019 06:32 AM
Last Post: Mike_Yealink
  T46G Forward off code sends code and Fwd to Number dwooster 3 4,143 12-18-2018 09:36 PM
Last Post: dwooster
  Group Call Pick Up showing original extension number stratos 1 3,346 07-31-2018 12:49 PM
Last Post: East_Yealink
  transferred phonecall not in history Marcroosict 5 6,239 10-06-2017 11:31 AM
Last Post: Chris Barron

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication