[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
V85 VPN no longer working
Author Message
gerdesj Offline
Junior Member
**

Posts: 1
Joined: Apr 2020
Reputation: 0
Post: #2
RE: V85 VPN no longer working
(06-22-2020 10:00 AM)avayax Wrote:  I tried an upgrade to V85 but the VPN no longer connects.
...
What's new or different about vpn in V85?

I have a T58 and can get OpenVPN working fine with V84 but it breaks with V85 and then starts working again on downgrade back to V84.

For reference here is the working vpn.cfg:

Code:
dev tun
tun-ipv6
persist-tun
persist-key
cipher AES-128-CBC
auth SHA1
tls-client
client
resolv-retry infinite
remote vpn.example.co.uk
port 443
proto tcp-client
ca /config/openvpn/keys/ca.crt
cert /config/openvpn/keys/client.crt
key /config/openvpn/keys/client.key
tls-auth /config/openvpn/keys/ta.key 1
remote-cert-tls server
comp-lzo adaptive
passtos

My OpenVPN server is on pfSense and to get the above working, I had to separate out the server name, port (443) and protocol (TCP). The pfSense export put them on one line. Note that unlike many examples in Yealink docs and posted in these forums, tls-auth does work at least on V84!

I don't have time to try all permutations by simply guessing and there seem to be no logs to look at for this.

V85 has a L2TP client added in and that does work with the pfSense implementation but I want to stick with OpenVPN for now.
07-22-2020 11:29 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
V85 VPN no longer working - avayax - 06-22-2020, 10:00 AM
RE: V85 VPN no longer working - gerdesj - 07-22-2020 11:29 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Phones no longer support Let Encrypt johnbeaumont 19 4,470 10-14-2021 05:32 PM
Last Post: yealink@vespino.nl
  Yealink WH62 UC not working with Cisco Webex oliragg 0 1,305 05-10-2021 05:18 PM
Last Post: oliragg
  V84.0.140, downgrade no longer possible? avayax 8 5,448 01-12-2021 08:44 PM
Last Post: avayax
  Jabra microphone not working with EHS40 Adapter chair 2 3,923 12-16-2020 05:11 AM
Last Post: Alex001
  Phones Web UI Not Working after Firmware Update Rockses 2 5,585 05-26-2020 02:44 PM
Last Post: Lewis-H
  Blind transfer not working on hangup bug mrabbitt@clarkecounty.gov 1 2,914 12-04-2019 04:33 PM
Last Post: Phil_Yealink
  W52P base unit no longer works RobertThompson 2 5,593 10-25-2019 07:40 AM
Last Post: FELIPE
  T41S admin login not working ayfrolov82 1 4,217 05-20-2019 12:34 PM
Last Post: Simons_Yealink
  Admin log in not working Vortex 5 9,473 03-17-2019 04:01 PM
Last Post: complex1
  LAn/Bridge not working DeepB 13 23,760 03-14-2018 02:29 PM
Last Post: JOHN124

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication