[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lost audio when answering a call between two T54W phones
Author Message
ash Offline
Junior Member

Posts: 11
Joined: May 2013
Reputation: 0
Post: #4
RE: Lost audio when answering a call between two T54W phones
(08-02-2019 06:08 PM)complex1 Wrote:  Hi,

In your test I miss 1 test... a call from a T42S to T54W.

Please try the T54W to T54W test again but now use codec PCMA or PCMU only and see if it happens again?

BTW: do you make use of a PBX?

We can reproduce the issue using a T54W to T54W using G729, PCMA, PCMU, if you answer and count 1, 2, 3 you will hear 2 or above. Using a G722 you always hear 1.

Worth noting in the earpiece you can also tell the RTP hasn't established yet either.

If using a T54W and a T42S all codecs work, you will always hear "1". This seems to point me in the direction of a T5X issue.

All tests performed using Ethernet, have tried PoE and Power Supplies.

The PBX is FreeSWITCH 1.8 and we've also tried 1.6 to ensure it isn't anything on FreeSWITCH.

@Yealink - The latest firmware was released in April, is there a T5X SIP BETA firmware I can get access to and see if it is a bug that has been addressed.

(08-02-2019 08:55 PM)jolouis Wrote:  Also are you running the T54W over wireless or on a wired connection?

I have a T53W, T54W and T57W here at my disposal so if you give me details I can test and try to investigate also.

I can PM details to our servers if you like for testing but if you were to do the following my theory is you should be able to reproduce:

- 2 x T54W running firmware T54W-
- Factory reset the phones and setup the basics to register to a PBX
- Remove all Codecs and have G729 as the only listed codec
- Dial from Extension A to B, Answer B and say 1 2 3 4 and see if you hear 1

The configuration we are using is this:

- PBX is hosted on a public IP in an external data centre
- The two test phones are behind a NAT router connecting to the PBX on the public IP

I will try the same test today using a PBX on the same network segment as the phones just to confirm it isn't a NAT based issue, but as we don't appear to see the issue on T4X, T3X, T2X phones I don't think this will be the issue.
(This post was last modified: 08-03-2019 01:47 AM by ash.)
08-03-2019 01:39 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Lost audio when answering a call between two T54W phones - ash - 08-03-2019 01:39 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Which Android Apps Can I Use on Yealink Android Phones? nolto 1 453 12-05-2022 09:39 PM
Last Post: complex1
  MP54 - Teams - Display Call Queue ID Hexanet 0 415 10-18-2022 04:33 PM
Last Post: Hexanet
  T54W with EXP 50 and WH62 stratos 2 2,344 10-14-2022 11:50 AM
Last Post: Scottie
  Bridge WiFi to PC? T54W webbyz 1 731 09-30-2022 05:20 PM
Last Post: complex1
  T54w stuck on welcome after power fail SSPhone 2 1,076 09-19-2022 10:29 PM
Last Post: Yisroel_MongoTEL
  T58 Call Park/Transfer Issues TieTech01 0 518 08-18-2022 08:48 PM
Last Post: TieTech01
  Call park Caller ID JonathanCPI 0 662 07-12-2022 03:26 AM
Last Post: JonathanCPI
  T54W Custom Templet Code charlie@duketel.com 1 1,194 06-09-2022 01:38 AM
Last Post: Yisroel_MongoTEL
  XML TextMenu Object Problem on T54W FW roemer_m 3 1,858 05-31-2022 02:17 PM
Last Post: roemer_m
  T54W w/DD10K not registering to RT30 Chris708 3 2,131 05-23-2022 10:50 PM
Last Post: Yisroel_MongoTEL

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication