[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
W56H handsets won't update to latest firmware.
Author Message
flowdesignstudio Offline
Junior Member

Posts: 2
Joined: Mar 2019
Reputation: 0
Post: #3
RE: W56H handsets won't update to latest firmware.
(03-11-2019 06:55 PM)complex1 Wrote:  
(03-11-2019 06:13 PM)flowdesignstudio Wrote:  We have a W60B base and 2 W56H handsets. The base has the latest firmware but the handsets will not keep the latest firmware, by that I mean they will revert themselves shortly after I manually update them. It's worth mentioning that these phones are autoprovisioned through RingCentral. Is anyone else having this or a similar issue?


It could be the firmware in the handsets are customized by RingCentral or other company.
Then most likely that’s why they revert to the previous installed firmware.
Please contact RingCentral and ask them if they are willing to help you to upgrade the firmware of the handsets.
What firmware version are the handsets running?

Hope this will help.


Thanks for the response. Yeah, I believe it was customized for RingCentral, they're running right now. I actually did exactly that with RC yesterday, or tried I should say. According to RC they were having issues because they were assisted provisioned as opposed to manually, so they tried to do it manually, but for whatever reason they wouldn't register when manually provisioned and I eventually said I'd rather have working handsets with old firmware than non functioning ones, at least until I can find a solution. So that's where I'm at now. Thanks again for the reply though. I appreciate all help.
03-11-2019 07:06 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: W56H handsets won't update to latest firmware. - flowdesignstudio - 03-11-2019 07:06 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  W56H initializing/boot loop n.vangelder 3 3,517 05-30-2023 08:33 PM
Last Post: Yisroel_MongoTEL
  Auto Provision firmware on W60B base station hospitale 6 6,196 02-15-2023 05:54 PM
Last Post: hospitale
  W56H handset no tones or ring swdatanet 2 5,030 12-14-2022 07:14 PM
Last Post: adamjames1
  All handsets on the same W60B loose registration after many attempts to register Alvaro Gutierrez 1 5,858 06-23-2022 09:56 PM
Last Post: rdurham
  W60B and W56H - can you PIN lock the phones,.. ? Haniel 2 8,722 06-18-2022 01:29 AM
Last Post: Beachnuttz
  W56H dB Levels Ryan587 2 6,642 05-14-2022 01:10 PM
Last Post: Simon from Sydney
  increase volume on earpiece on W56H handset? Simon from Sydney 0 2,576 05-14-2022 01:08 PM
Last Post: Simon from Sydney
  Handsets LED not indication Voicemail notification Bob_ 0 1,832 05-08-2022 09:50 PM
Last Post: Bob_
  yealink w60p data initializing (W56H) gijoe 4 14,154 01-26-2022 06:17 PM
Last Post: complex1
  W60B base firmware downgrade RingCentral brewginger 2 5,276 01-18-2022 12:58 AM
Last Post: brewginger

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication