[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T27G - Fall Back issues - Successive setting [Solved]
Author Message
BobBluePackets Offline
Junior Member
**

Posts: 10
Joined: Dec 2017
Reputation: 1
Post: #7
RE: T27G - Fall Back issues - Successive setting [Still an issue]
Just posting back now that I have a reason and a solution.....Thank you for all the posts.

As mentioned, in a simple setup (Lab) the fail over function works and works as expected.

To resolve this issue, I completely built up a complete working replica of what we had setup in a production environment (sans as many phones).

Again, with the simple setup, it worked as was the expectation....

However with this setup, I went further and performed the manual sync we do on the production systems. As soon as I completed this, the issue appeared. Phones appear to be registered on both systems.

After a lot of debugging and at least some clearer direction of what could be the possible cause....

Found that the restore of the Primary PBX to the Secondary PBX, is also restoring the Asterisk database. This database contains the Registration states of all the phones, which is naturally carried across the to the Secondary PBX.

Now I have not had time to look at further, but from what I can see, the PBX is sending a keep alive to the phone, getting a response, keeping the record/state in play, and when a phone goes to make a call, it appears to be randomly selecting which PBX to make the call out on...(which could be based on registration refresh vs Qualify timings)..probably something to research on the next rainy weekend.

Anyhow.....the fix is when restoring the database, perform

database deltree registrar/contact on the secondary PBX

This will clear the registrations.....

After this all testing worked perfectly. Killed the primary server, phones started registering with the secondary. Bring the primary back online, phones deregister on the secondary and re-register on the primary - perfect.

Hope it helps someone....

Regards

Bob
05-28-2019 04:47 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
RE: T27G - Fall Back issues - Successive setting [Still an issue] - BobBluePackets - 05-28-2019 04:47 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  SIP-T27G and WF50 pdjhh 0 271 08-24-2020 04:34 AM
Last Post: pdjhh
  VP59 - Teams-to-Teams Federated User issues darwin.ranzone@originnet.com 0 404 07-23-2020 04:41 PM
Last Post: darwin.ranzone@originnet.com
  T27G - BT40 - CP700 jakthree 2 773 06-15-2020 04:08 PM
Last Post: jolouis
  T27G openvpn systems 4 3,564 03-16-2020 10:08 AM
Last Post: free2k
  T27G admin password Nenad 1 1,198 11-19-2019 02:24 PM
Last Post: complex1
  Possible to have T27P switch back to first page of DSS Keys after a period of time? Bobcat19 2 3,789 11-13-2019 07:37 AM
Last Post: Ajani_Exetel
  "Hold" + going back by "Resume" - audio is muted Babylonia 1 1,202 07-10-2019 08:25 PM
Last Post: Babylonia
  T27G firmware phnau 1 1,670 05-21-2019 10:19 AM
Last Post: complex1
  Screen Default Back to Page 1 Kiwi 0 949 04-16-2019 01:22 AM
Last Post: Kiwi
  Different users on the same phone on SIP-T27G econnet 2 2,290 01-02-2019 01:46 PM
Last Post: jolouis

Forum Jump:


User(s) browsing this thread:

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication