New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Echo when using headset on T46S and T42G
Author Message
IZT-crobinson Offline
Junior Member

Posts: 1
Joined: Nov 2018
Reputation: 0
Post: #1
Echo when using headset on T46S and T42G

I have a plantronics C054 headset and I am getting echo in whatever the caller is saying. I contacted the seller of the headset and told them it was defective, so they send me another one, and I have the same issue. I tried lowering the volume and everything. I tried the switch on the bottom and I either get a combonation of these:

1) Can't hear dialtone
2) Can't hear caller
3) Caller can't hear me

All I want is this to work, but now I am thinking it might be the phones themselves.

Any help is much appreciated.
11-27-2018 02:25 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
Echo when using headset on T46S and T42G - IZT-crobinson - 11-27-2018 02:25 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  set caller ID of T46S bjoernie 0 25 12-07-2018 12:08 AM
Last Post: bjoernie
  T46S Speed dial problem chrischevy 3 128 12-03-2018 02:24 PM
Last Post: jolouis
  T46S on Yeastar S50 - Voice Box Problems ZOOMsoft 0 51 11-29-2018 05:42 PM
Last Post: ZOOMsoft
  T46S SfB CAP always uses PSTN SebastianM 0 80 11-16-2018 01:07 PM
Last Post: SebastianM
  T42G recovery files needed Global Data Systems 0 101 11-12-2018 09:15 PM
Last Post: Global Data Systems
  Connecting Yealink T46S to Vodafone's One Net Business Servers Matthias Hink 0 86 11-09-2018 11:46 AM
Last Post: Matthias Hink
  Unstable bandwith with T42S/T46S SD321-GYHS 0 114 10-29-2018 02:01 PM
Last Post: SD321-GYHS
  t46s calls on hold operation comstar 3 233 10-27-2018 04:13 PM
Last Post: arcommct
  XML LockIn Not working for headset nickpl 0 125 10-12-2018 02:47 PM
Last Post: nickpl
  T46s Downgrade Alexander97 0 174 10-12-2018 12:38 PM
Last Post: Alexander97

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication