New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit :

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T42G recovery files needed
Author Message
Global Data Systems Offline
Junior Member

Posts: 2
Joined: May 2017
Reputation: 0
Post: #1
T42G recovery files needed
Im needing the T42G recovery files. The phon e is stuck at initializing. Ive tried to upload my current version T42- by holding the speaker when booting and pointing the phone to my TFTP server however the phone indicates "update failed"
11-12-2018 09:15 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
T42G recovery files needed - Global Data Systems - 11-12-2018 09:15 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T42G with firmware T42- compsos 1 128 02-03-2020 07:48 PM
Last Post: complex1
  Recovery Mode Challenger VoIP 1 562 12-02-2019 11:14 AM
Last Post: Jacky_Yealink
  [SOLVED] OpenVPN not doing anything T42G V83 Danariel 4 1,021 09-15-2019 11:35 AM
Last Post: benaam433
  T41S recovery from TFTP fails jwhopkins 3 1,047 07-25-2019 01:19 AM
Last Post: Baron_Yealink
  Move from SfB to Teams with T42G helios.comms 0 453 05-21-2019 07:51 PM
Last Post: helios.comms
  T46s : recovery mode doesn't works and phone doesn't boot Quentin-F 0 729 04-09-2019 08:07 AM
Last Post: Quentin-F
  T48G Recovery Files Needed gigaboy 3 1,750 01-23-2019 03:49 PM
Last Post: jolouis
  Echo when using headset on T46S and T42G IZT-crobinson 0 780 11-27-2018 02:25 AM
Last Post: IZT-crobinson
  T42S/G Recovery Firmware 0 999 11-06-2018 07:59 PM
Last Post:
  T46S recovery mode doesn't upload .rom file, Always "Start Updating..." andreas1984 1 2,271 08-27-2018 09:03 AM
Last Post: LOIC

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication