[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T42G - Impossible to upgrade firmware
Author Message
psanmartin Offline
Junior Member

Posts: 3
Joined: Aug 2018
Reputation: 0
Post: #6
RE: T42G - Impossible to upgrade firmware
(08-22-2018 12:27 PM)complex1 Wrote:  
(08-22-2018 11:29 AM)psanmartin Wrote:  
(08-22-2018 08:28 AM)complex1 Wrote:  
(08-21-2018 07:46 AM)psanmartin Wrote:  Hi all,

I have tried to update my T42G firmware and I can't. My steps:
- Download firmware from http://support.yealink.com/documentFront...umentId=11

- Access to phone web page Settings - Upgrade and put the updated firmware and Upgrade

All looks like normal (i can see updating firmware on phone display) but after reboot firmware doesn't upgrade. Have anyone any idea?

I have checked with some firmwares with the same result.

Model: Yealink T42G
Versión Firmware:
Versión hardware:



It looks like your phone is running on customized firmware (, what’s why the upgrade failed.
Please contact your reseller or provider and ask them to help you.

Hope this will help.

Thanks for your answer. Unfortunately, we haven't any way to contact with our provider Sad . So, do you know if there is any way to reset phone to any standard version?


I can’t help you any further. Sorry about that.
Please find out who is the distributor of your country and ask them if they are willing to help or sent a mail directly to Yealink Support or submit a support ticket.

Hope this will help.

Thanks. I'll analize options.
08-22-2018 01:24 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: T42G - Impossible to upgrade firmware - psanmartin - 08-22-2018 01:24 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T42S unable to update firmware brianstoiber 4 504 Today 09:50 PM
Last Post: complex1
  Cannot export any files T42G Telcopc 0 120 09-23-2022 03:18 AM
Last Post: Telcopc
  Yealink T42G Phone stuck at Welcome LFC 12 21,511 08-08-2022 04:16 PM
Last Post: markvdheijden
  Yealink T48s Firmware update failed dangmoss 2 3,077 02-19-2022 03:09 AM
Last Post: dangmoss
  Problem Change Firmware T48s from SFB to SIP Lars Maschke 2 3,094 01-14-2022 10:22 AM
Last Post: kumagera
  Yealink T42S and T42G Phone stuck at Welcome Pierre06 7 5,563 01-10-2022 11:36 PM
Last Post: Pierre06
  T42G - Stuck at Welcome screen clevoip 1 2,736 10-15-2021 01:28 AM
Last Post: complex1
  Need to remove custom Fonality firmware 1CCT 16 28,158 05-03-2021 08:24 PM
Last Post: kmconklin
  SIP-T46s Bricked after latest firmware update. daniel.broome 2 5,284 04-27-2021 11:39 AM
Last Post: daniel.broome
  OEM Firmware change NotKnown 1 3,567 04-14-2021 07:41 PM
Last Post: complex1

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication