[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T22P -0 3CX firmware web server fails
Author Message
will3 Offline
Junior Member

Posts: 4
Joined: Apr 2018
Reputation: 0
Post: #2
RE: T22P -0 3CX firmware web server fails
(03-23-2018 03:50 AM)preterion Wrote:  I hope someone has an explanation for this weird behavior:

We have two separate 3CX installations using Yealink T22P phones. Until upgrading to latest 3CX version and latest Yealink T22P firmware, things were ok.

After the upgrade, we have the following behavior that occurs after a while:

- Phones stop responding to Remote Control commands (CTI mode in 3CX)
- The phones web interface also becomes unavailable

After a reboot, the phones behave normally, until after a while when they lock down again.

We have tried using the phones in various configurations - provisioned by the 3CX system or manually configured.
We made sure remote control is allowed from "any".

It seems to me that the firmware pushed by 3CX ( is at fault - either causing the phone to blacklist the local subnet (or any IP) or by simply crashing the web server after a while. I would guess it is the latter based on the behavior (i.e. works and then stops working after random number of minutes).

I find this issue really disturbing - regardless of the fact that the phones are not supported anymore. Any vendor has an obligation to make sure older equipment can still be used in the long term and the fact that the latest versions (3CX + Firmware) are basically rendering the phones useless is deeply upsetting..

We did extensive testing and it looks like the firmware version pushed by 3CX is heavily customised and causes this behavior. Apparently, 3CX has reported this issue to Yealink but there was no action taken.

Whilst I understand this model is EOL, I can't understand why a vendor would ignore reports of a fault that renders the product useless. It is basic duty of care - you sell a product and provide a firmware upgrade, at least make sure IT WORKS!

i have experienced this same behavior in the past, i could exacerbate the problem by removing the 3cx server from the local network for a time, by unplugging the network cable for 5 - 10 min, the affected phones would not be able to re-provision unless i power cycled them.

the first thing i would try is removing all the blf keys/lamps, in my quest to find the cause i found that phones with no blf keys for shared parking extensions etc are immune to the issue.

i never did find the cause and ended up just moving all the phones to a new vlan, which helped the issue but did not remove it completely as anytime the server is down for 5 plus min some of the phones will still "stick" and need to be power cycled.

best of luck.
04-17-2018 02:35 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: T22P -0 3CX firmware web server fails - will3 - 04-17-2018 02:35 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T21P E2 firmware upgrade janp 0 1,668 01-27-2024 02:43 AM
Last Post: janp
  Dial-Now fails to recognize time-out braymond 2 10,577 01-31-2023 05:33 PM
Last Post: eddie79it
  Firmware upgrade fails on T21P E2 p.pasquino@technology4you.it 0 5,569 11-02-2021 04:42 PM
Last Post: p.pasquino@technology4you.it
  T21P Stuck on "Initializing" - Recovery Mode Fails` YCMJamie 5 13,917 08-24-2021 07:04 PM
Last Post: YCMJamie
  [Solved] Correct password don't work anymore in SIP-T22P ip phones frog.tech 1 8,672 01-27-2021 07:45 PM
Last Post: lsk
  T21P_E2 firmware 84.0.125 slow with VLAN GwenH 3 12,493 11-03-2020 11:01 PM
Last Post: complex1
  how to connect yealink T23G to mikrotik openvpn server m.taghavi 4 14,107 10-11-2020 11:31 AM
Last Post: bozko
  T26P Can not upgrade firmware martien.poels@bank2loyalty.com 2 9,729 09-21-2020 05:16 PM
Last Post: complex1
Lightbulb Yealink T28P Firmware Upgrade Fails Michelth 11 55,760 06-27-2020 10:13 AM
Last Post: complex1
  default username/password not working after firmware upgrade tfrohling 3 37,990 02-15-2020 01:30 PM
Last Post: khalidnisar

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication