New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Caller-id after attended transfer not working properly on T19P/T41P
Author Message
Lucia_Yealink Offline
Super Moderator
******

Posts: 470
Joined: Aug 2016
Reputation: 4
Post: #6
RE: Caller-id after attended transfer not working properly on T19P/T41P
Dear Customer,

For this parameter, it works for both invite and update message which pbx send to the phone to refresh the caller id.
account.X.cid_source=
0:FROM
1:PAI
2:PAI-FROM
3:PRID-PAI-FROM
4:PAI-RPID-FROM
5:RPID-FROM
I just check the pcap you provide and locate the problem, in your situation, the pbx send two update message to the T41P, both of the two update contact the PAI.
The fisrt one is: P-Asserted-Identity: "Daniel Diaz" <sip:142@10.176.255.0>\r\n
The second is: P-Asserted-Identity: "227605147" <sip:227605147@10.176.255.0>\r\n

The phone read the caller id from the PAI of the first update message.
Suggestion: Please let the pbx send only one update message with the correct PAI.
02-06-2018 08:01 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Caller-id after attended transfer not working properly on T19P/T41P - Lucia_Yealink - 02-06-2018 08:01 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T19P E2 auto provision firmware. NI 1 1,183 10-08-2018 05:15 PM
Last Post: NI
  Does not answer properly when in a ring group davemcbr 4 2,109 06-01-2018 02:02 AM
Last Post: Michael_Yealink
  T41P: Error when uploading ringtones DanielFrank 3 7,321 01-03-2018 07:00 AM
Last Post: Billiem
  T19P E2 recovery files jgonzalez 1 1,871 12-22-2017 12:35 AM
Last Post: Aishion_Yealink
  T41P will not register DavidAC 2 2,800 07-12-2017 11:44 AM
Last Post: Phonism
  T41P not registering DavidAC 1 1,970 06-23-2017 07:03 AM
Last Post: Kevin_Yealink
  t19p recovery files? freefall2900 7 8,758 11-21-2016 12:15 PM
Last Post: Siegfried05
  Recovery Mode for T41P not working Tonyn 1 3,796 11-21-2016 07:13 AM
Last Post: Yealink_Michael
  Yealink T19P Action URI denis 1 3,113 10-19-2016 09:07 PM
Last Post: denis
  SIP-T19P E2 DTMF not working with g.729 seulater 1 2,703 09-29-2016 11:29 AM
Last Post: Travis_Yealink

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication