[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Caller-id after attended transfer not working properly on T19P/T41P
Author Message
ddyx Offline
Junior Member

Posts: 5
Joined: Oct 2015
Reputation: 0
Post: #1
Caller-id after attended transfer not working properly on T19P/T41P

I have read many posts about this issue and have tried the proposed solutions to no avail.

I'm using a T19P (E2) phone and a T41P phone for the tests. So, the scenario is similar as described on other posts:
1. Incoming call to T19P
2. T19P answers
3. T19P makes a new call to T41P
4. T41P answers
5. T19P performs an attended transfer
6. Caller id shown on T41P's display still shows T19P data and does not update with the original incoming call caller id (name/number)

My first tests were on some of the 80s firmware versions, then I upgraded both phones to the latest 82, because the only documentation that confirmed the existence of the "refresh_remote_id" parameter was on the autoprovisioning template files of the version 82.

After provisioning both phones with this new parameter enabled (through autoprovision), I downloaded the configuration in order to check if the parameter was or wasn't configured, and it turned out that it didn't appear on the downloaded configuration. I tested in spite of this evidence, and of course it didn't work.

Since there is no documentation about what RFC this new parameter supports, it's even more difficult to make modifications on my system to satisfy Yealink phones limitations (for example RFC 5876 doesn't seem to be supported, and it would be of great help to use PAI on UPDATE requests instead of FROM).

I still haven't tested it on other phone models, but I need this to work on these.

Best regards.
01-31-2018 01:17 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
Caller-id after attended transfer not working properly on T19P/T41P - ddyx - 01-31-2018 01:17 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  MP50 working in Citrix chinacat 1 5,082 08-15-2023 03:13 AM
Last Post: ameyer22
  T19p E2 recovery firmware Jensen 1 2,838 10-25-2022 07:33 PM
Last Post: complex1
  MP56 phones crashing whilst consult/transfer Teams calls mjuliano 1 3,343 09-27-2022 11:26 PM
Last Post: guillaume.novo
Brick MP50 stuck after call transfer af@benenden.school 4 9,378 12-22-2021 07:24 PM
Last Post: af@benenden.school
  MP50 Transfer Calls? pbregistrations@yourprofitbuilders.com 1 8,307 09-08-2021 02:48 AM
Last Post: microdaft
  T58 Call Park and Transfer Problems user42491 1 5,560 08-03-2021 09:24 PM
Last Post: complex1
Question T23G Gigabit dont working hesilva 0 3,096 07-13-2021 07:23 AM
Last Post: hesilva
  [SOLVED] T41S and T41P problems with backlight jeroentjed 11 26,032 02-06-2021 06:21 PM
Last Post: complex1
  T19P E2 auto provision firmware. NI 1 7,533 10-08-2018 05:15 PM
Last Post: NI
  Does not answer properly when in a ring group davemcbr 4 9,831 06-01-2018 02:02 AM
Last Post: Michael_Yealink

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication