[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LDAP lookup doesn't work, though directory is basically searchable (T56A / T58)
Author Message
Mr_Christian Offline
Junior Member
**

Posts: 3
Joined: Jan 2018
Reputation: 0
Post: #3
RE: LDAP lookup doesn't work, though directory is basically searchable (T56A / T58)
Hi Samuel,

I just seem to have figured it out myself a few minutes ago. Having tried various configurations I ended up with the following:

ldap.name_filter = (|(searchContact=%)(searchNumber=%))
ldap.number_filter = (|(searchContact=%)(searchNumber=%))

Though I already tried this configuration before, it is working now. I guess the reason it didn't work before was that the telephone system, the phone and the LDAP had different representations of the number. Let's try to explain what presumably was happening:

Within the 3CX telephone system I replaced +49 with 0 respectively + with 00. This lead to the phenomenom that the phone got the number without leading country code. (The reason for this number transformation was that I wanted to be able to dial calls from the missed calls list from within the 3CX softphone and this didn't send the + sign to the phone ending up in a wrong number. I later figured out that there was an option to automatically change the + sign with 00.)

Within the LDAP the number also has a leading + sign. Though the search functionality of our phone finds the number ignoring different number formats, it always replies with a number having the leading +. This seemed to confuse the phone.

The last part of the riddle was to find out that the phone treats all numbers with a leading + sign as a string and therefor queries the LDAP using the name- instead of the number-filter. Thus always searching both fields did the trick.

If someone else runs into the same problem: Always double check that the number sent from the telephone system and the one that comes from the ldap are in the same format. And keep in mind that the phone treats numbers with a + sign as names. That's it. Smile

Thanks a lot for the offered help. I might come back to you if there is something still not working.

Best regards

Chris

PS: It would be great to know how the phone works internally. Am I right that the number sent back from the LDAP is double checked within the phone? And does the phone really handle numbers with the + sign as strings and thus uses the name filter instead of the number filter? Thanks a lot for clarification - I gues this would help others struggling with the LDAP feature a lot!
01-26-2018 01:59 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
RE: LDAP lookup doesn't work, though directory is basically searchable (T56A / T58) - Mr_Christian - 01-26-2018 01:59 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Teams - T56a offline in Teams admin panel after 131 brandone 16 23,616 09-06-2023 08:53 AM
Last Post: ITSourcePro
  Show local directory name with caller id colcc 0 707 08-24-2023 01:38 PM
Last Post: colcc
  T56A Upgrade SIP to Teams wpolakoff 1 1,225 07-12-2023 07:49 PM
Last Post: complex1
  T56a sfb Firmware needed Henning Cohrs 1 1,365 06-22-2023 04:10 PM
Last Post: complex1
  Fixed - T56A Unresponsive Icons on Main Screen Gryz 1 1,200 06-01-2023 09:56 PM
Last Post: Gryz
  T58W - Reset does not Work - USB Failed brycefirst 0 1,520 03-07-2023 05:44 PM
Last Post: brycefirst
  T57W LDAP delays wp92 0 1,465 03-05-2023 10:52 PM
Last Post: wp92
  after factory reset admin password don't work systemlift 1 1,952 12-23-2022 08:12 PM
Last Post: systemlift
  Yeastar S100 and T54W BLF visual alert name LDAP gugaua 2 3,304 04-22-2022 12:08 AM
Last Post: complex1
  Remote phonebook - T56A - Failed to download baohan97 3 8,737 03-10-2022 06:11 PM
Last Post: complex1

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication