[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Register Failed on T22P to MyPBX U100
Author Message
Yealink_Michael Offline

Posts: 382
Joined: Jul 2015
Reputation: 2
Post: #2
RE: Register Failed on T22P to MyPBX U100
(07-13-2015 01:05 PM)Firewall Wrote:  I'm setting up a MyPBX U100 for a client using PSTN trunking, and Yealink T22P handsets (Firmware version, hardware version

I've setup all the required extensions, then through the PBX added the phones (via phone provisioning), and they all added fine, and settings configured in the PBX show up on the phone ok.

However when trying to make calls, I get a "forbidden (bad auth), and I can see that on the phone's account status, it is showing "Register Failed". Can also see that on the PBX status, all extensions are displaying as 'unavailable'. Have tried adding 3 phones so far, and they all have the same issue.

I've confirmed that the details between the handsets and the phones is correct (e.g. name, labels, password etc).

Would greatly appreciate any pointers on what to look at, as on the face of it, it seems like a straight forward process, but I just can't get the handsets to register.


for this issue, please try first upgrade to the last firmware , firmware download link : http://support.yealink.com/documentFront...umentId=21

firmware number :,

if issue still exist. then twe need trace file to see why the phone will register failed , trace file including pcap file, config bin and syslog file , for how to get them , please refer to the FAQ below:


if you collect the files we needed ,you can send it to our support team : support@yealink.com then we will follow up !
07-13-2015 05:16 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: Register Failed on T22P to MyPBX U100 - Yealink_Michael - 07-13-2015 05:16 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T26P failed to register with TLS transport tvt 0 1,556 10-29-2021 02:58 PM
Last Post: tvt
  [Solved] Correct password don't work anymore in SIP-T22P ip phones frog.tech 1 5,150 01-27-2021 07:45 PM
Last Post: lsk
  T21P Register Failed agatospk 6 11,914 01-31-2020 06:08 AM
Last Post: agatospk
  T22P Action URI ATrans and BTrans not working? DaveThompson 2 9,160 09-10-2019 10:47 AM
Last Post: DaveThompson
  T22P Stuck on FW justingoldberg 0 3,011 08-16-2019 01:19 PM
Last Post: justingoldberg
  T21P: Failed to upload wave file sawaix 2 6,221 03-27-2019 12:07 AM
Last Post: sawaix
  T22P DSSKey linekey labels andcza 2 7,210 05-10-2018 06:02 AM
Last Post: andcza
  T22p does not get IP, and does not access the web interface even by manually config jason.luka 5 9,540 04-18-2018 01:29 AM
Last Post: anonymous1654103749851
  T22P -0 3CX firmware web server fails preterion 1 6,274 04-17-2018 02:35 PM
Last Post: will3
  SIP T22P Problem liamretrams 2 8,460 06-01-2017 11:22 AM
Last Post: wcolato

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication