New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T41P will not register
Author Message
Jensen_Yealink Offline
Administrator
*******

Posts: 98
Joined: Jan 2012
Reputation: 0
Post: #2
RE: T41P will not register
(05-31-2017 01:57 AM)DavidAC Wrote:  Sorry if this has already been covered - I'm not finding it if it has.
Testing a new system with a single Yealink T41P phone.

Phone: T41P - Firmware: 36.81.0.90
(First thing out of the box, I updated the firmware on the phone, using the instruction manual as a guide.)
IP Address: 10.1.10.202

Asterisk system – Ver: 13.13.1
IncrediblePBX Ver: 12.0.74
IP Address: 10.1.10.4

No firewall separating the phone and the server, both using the same switch with no VLANS configured.

Loaded and updated IncrediblePBX, changed Ext 701 User password to match the list I’m using. Configured phone to match User ID (701) and password. The phone will not register. I tried various settings changes on both the server and the phone, but phone still will not register.

Frustrated and wondering if I had changed too many things between the phone and the server, I wiped out the Asterisk system and reloaded clean. I then reset the phone to factory settings. Finally, I changed password for Ext User 701, as before, and then configured phone as before. It still would not register.

I ran full capture of config and pcap. That is all zipped into one file and attached.

I also opened the pcap file using Wireshark. While filtering for only traffic between the phone and the server, I found several attempts by the phone to register with the server. In the server’s reply for each attempt, there was an error “Header not terminated by empty line (CRLF)” I don't know if that is significant, but warnings and errors in responses like that worry me when systems don't work as anticipated.

Any help that anybody can provide will be very appreciated.

Hi DavidAC,

I look into the PCAP, the phone sent registered request to the server, but don't get response from it. so the phone keep sending register request.
From the config.bin, the account info seems not full type in(auth name is empty).
So please check the config and the server side.
below i also attach the quick start guide for your reference.
have a nice day.
06-26-2017 03:34 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
T41P will not register - DavidAC - 05-31-2017, 01:57 AM
RE: T41P will not register - Jensen_Yealink - 06-26-2017 03:34 AM
RE: T41P will not register - Phonism - 07-12-2017, 11:44 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T23G register failed roberto.cartella 0 1,188 02-13-2018 12:14 PM
Last Post: roberto.cartella
  Caller-id after attended transfer not working properly on T19P/T41P ddyx 5 3,443 02-06-2018 08:01 AM
Last Post: Lucia_Yealink
  T41P: Error when uploading ringtones DanielFrank 3 7,321 01-03-2018 07:00 AM
Last Post: Billiem
  T41P not registering DavidAC 1 1,970 06-23-2017 07:03 AM
Last Post: Kevin_Yealink
  Recovery Mode for T41P not working Tonyn 1 3,796 11-21-2016 07:13 AM
Last Post: Yealink_Michael
  T41P and OpenVPN Mad_k_57 1 2,852 09-26-2016 10:55 AM
Last Post: Travis_Yealink
  How to use the Intercom feature on a T41P Jderek01 1 6,150 09-19-2016 05:44 PM
Last Post: Kevin_Yealink
  T41P: Account 1 and 2 won't register? gatorphan 9 12,755 02-12-2016 04:41 PM
Last Post: rdoyle1000
  T41P VPN Not Working TechnoKhan 2 3,680 08-12-2015 10:21 PM
Last Post: TechnoKhan
  T41P - STP Issue caleman 1 4,062 08-07-2015 05:23 AM
Last Post: Yealink_Michael

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication