[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T41P not registering
Author Message
Kevin_Yealink Offline

Posts: 204
Joined: Jul 2016
Reputation: 2
Post: #2
RE: T41P not registering
(05-31-2017 01:55 AM)DavidAC Wrote:  Sorry if this has already been covered - I'm not finding it if it has.
Testing a new system with a single Yealink T41P phone.

Phone: T41P - Firmware:
(First thing out of the box, I updated the firmware on the phone, using the instruction manual as a guide.)
IP Address:

Asterisk system – Ver: 13.13.1
IncrediblePBX Ver: 12.0.74
IP Address:

No firewall separating the phone and the server, both using the same switch with no VLANS configured.

Loaded and updated IncrediblePBX, changed Ext 701 User password to match the list I’m using. Configured phone to match User ID (701) and password. The phone will not register. I tried various settings changes on both the server and the phone, but phone still will not register.

Frustrated and wondering if I had changed too many things between the phone and the server, I wiped out the Asterisk system and reloaded clean. I then reset the phone to factory settings. Finally, I changed password for Ext User 701, as before, and then configured phone as before. It still would not register.

I ran full capture of config and pcap. That is all zipped into one file and attached.

I also opened the pcap file using Wireshark. While filtering for only traffic between the phone and the server, I found several attempts by the phone to register with the server. In the server’s reply for each attempt, there was an error “Header not terminated by empty line (CRLF)” I don't know if that is significant, but warnings and errors in responses like that worry me when systems don't work as anticipated.

Any help that anybody can provide will be very appreciated.

Hi David

I check those file and i find that phone send register packet out, but it will get error 'destination unreachable', so please check network between phone and server.

If the issue still persist, please also export syslog from Asterisk server. Let me know if any update.

06-23-2017 07:03 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
T41P not registering - DavidAC - 05-31-2017, 01:55 AM
RE: T41P not registering - Kevin_Yealink - 06-23-2017 07:03 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T27G - DNS SRV not registering to updated IP jrobs 0 2,203 12-02-2021 03:54 AM
Last Post: jrobs
  [SOLVED] T41S and T41P problems with backlight jeroentjed 11 22,482 02-06-2021 06:21 PM
Last Post: complex1
  Caller-id after attended transfer not working properly on T19P/T41P ddyx 5 13,503 02-06-2018 08:01 AM
Last Post: Lucia_Yealink
  T41P will not register DavidAC 2 9,588 07-12-2017 11:44 AM
Last Post: Phonism
  Recovery Mode for T41P not working Tonyn 1 9,552 11-21-2016 07:13 AM
Last Post: Yealink_Michael
  T41P and OpenVPN Mad_k_57 1 6,903 09-26-2016 10:55 AM
Last Post: Travis_Yealink
  How to use the Intercom feature on a T41P Jderek01 1 12,985 09-19-2016 05:44 PM
Last Post: Kevin_Yealink
  T41P: Account 1 and 2 won't register? gatorphan 9 28,139 02-12-2016 04:41 PM
Last Post: rdoyle1000
  T41P: Error when uploading ringtones DanielFrank 2 12,266 09-07-2015 10:12 PM
Last Post: rawbynature
  T41P VPN Not Working TechnoKhan 2 7,914 08-12-2015 10:21 PM
Last Post: TechnoKhan

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication