[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Local DHCP doesnt work when OpenVPN is enabled
Author Message
davids@btni.co.uk Offline
Junior Member

Posts: 1
Joined: Jun 2015
Reputation: 0
Post: #1
Local DHCP doesnt work when OpenVPN is enabled
I have managed to get the OpenVPN connection working from my Yealink T28 to FreePBX OpenVPN, however this was using a static IP address on the phone. As soon as I turn it to DHCP the phone just sits on obtaining IP address.

We need them to be configured to use DHCP so that normal users can take the phones home and plug into the home networks, no matter what way their home networks are configured.

Ideally it should get a local IP address first, and then dial the VPN and get its tunnel address and finally find the PBX.

As soon as I give the phone a static IP address it connects to the VPN and registers against FreePBX.

If I turn off VPN it will pick up a dhcp address straight away (after it reboots) so I know my dhcp server is ok.

Some specs
Windows 2012R2 DHCP - no VLAN - 192.168.xx.xx network
OpenVPN network - 10.0.8.xx
I have tried the phone through two different PoE switches, cisco and netgear.

I will gather up some logs and post then here shortly, but thought I would put the question out in case someone has came across this issue before.

Update - No logs are recorded on the windows server, and as the phone gets rebooted before I can connect to it, its logs don't show anything before the reboot. Correct me if i'm wrong or if you know how I can see the logs of it failing to get a dhcp address?
(This post was last modified: 06-23-2015 07:24 AM by davids@btni.co.uk.)
06-23-2015 07:08 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
Local DHCP doesnt work when OpenVPN is enabled - davids@btni.co.uk - 06-23-2015 07:08 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Passing only LDAP traffic through OPENVPN Commensus 0 2,125 02-23-2022 09:47 PM
Last Post: Commensus
  Configuring OPENVPN with Yealink Commensus 0 2,630 02-23-2022 09:45 PM
Last Post: Commensus
  Remote or local directoy : avoid groups 4Next 2 4,292 02-01-2022 04:22 AM
Last Post: 4Next
  DHCP not working on T26P when OpenVPN is enabled. LandonL 11 36,643 05-12-2021 10:46 AM
Last Post: 1sae
  Solved Openvpn.tar creating the right size file compsos 3 8,509 08-20-2020 06:49 AM
Last Post: complex1
  Action URL does not work danield 2 11,019 07-31-2020 09:00 PM
Last Post: brickman
  Detailed boot process and ways to add local configuration? DanH 2 7,606 10-16-2019 04:24 PM
Last Post: justingoldberg
  BLF no work in Unify OpenScape Business marioruiz_2811 4 11,860 05-22-2019 02:52 PM
Last Post: turiatel
  OpenVPN and QoS/TOS roelvanmeer 0 4,663 02-19-2019 09:27 AM
Last Post: roelvanmeer
  OpenVPN Timeout connecting p2xt 3 10,328 07-13-2018 07:37 PM
Last Post: jolouis

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication