[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T21P E2 OpenVPN Disconnects
Author Message
acca Offline
Junior Member

Posts: 2
Joined: Nov 2016
Reputation: 0
Post: #2
RE: T21P E2 OpenVPN Disconnects
Problem solved. My local and remote networks had the same CIDR. I've changed the subnet on one side, and now everything works.

Best Regards,


(11-02-2016 12:50 PM)acca Wrote:  Hello Everyone,

My OpenVPN-server side is based on the pfSense OpenVPN router. I've configured the tunnel for SIP clients, and I have two older T20P phones which are using the tunnel, and work flawlessly.

I've got two T21P E2 phones, which are configured using the same vpn.conf file and different certificates. Initially, everything works fine. Phone will connect to the OpenVPN server, and asterisk. After the period of inactivity (approximately 2-5 minutes), T21P drops the VPN connection, and becomes unreachable. T20P is working all the time.

On the VPN server side, I see the timeout message, and failure to communicate to the T21P. After rebooting the phone it works for few minutes, and fails again.

I've tried to modify the T20's client configuration file to use it with T21. Currently it looks as follows:

dev tun
cipher AES-128-CBC
auth SHA1
#resolv-retry infinite
reneg-sec 604800
sndbuf 100000
rcvbuf 10000
auth-retry nointeract
remote server.ip.address 1197 tcp
ca /config/openvpn/keys/ca.crt
cert /config/openvpn/keys/client1.crt
key /config/openvpn/keys/client1.key
tls-auth /config/openvpn/keys/ta.key 1
ns-cert-type server
comp-lzo no
verb 3

Do you have any suggestion? I've been checking the phone's logs, but couldn't find anything OpenVPN related. When phone drops the tunnel, I have to disable VPN manually and device will reboot. Logs are empty after reboot.

Best Regards,

11-02-2016 07:53 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
T21P E2 OpenVPN Disconnects - acca - 11-02-2016, 12:50 PM
RE: T21P E2 OpenVPN Disconnects - acca - 11-02-2016 07:53 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T21P E2 firmware upgrade janp 0 2,682 01-27-2024 02:43 AM
Last Post: janp
  T28P - OpenVPN TLS error: Unsupported protocol 1sae 0 1,547 07-18-2023 06:50 AM
Last Post: 1sae
  T21P TLS - Trusted CA TheCourier 0 1,253 07-17-2023 04:34 PM
Last Post: TheCourier
  T21P E2 - Custom Ringtone Darleen 3 5,581 07-26-2022 10:40 PM
Last Post: complex1
  T21P Low headset volume rmatuda 14 47,634 11-02-2021 08:39 PM
Last Post: overlay
  Firmware upgrade fails on T21P E2 p.pasquino@technology4you.it 0 5,940 11-02-2021 04:42 PM
Last Post: p.pasquino@technology4you.it
  T21P Stuck on "Initializing" - Recovery Mode Fails` YCMJamie 5 15,187 08-24-2021 07:04 PM
Last Post: YCMJamie
  T21P E2 default Programmable Key label in V84 erictam 6 17,610 10-28-2020 10:32 PM
Last Post: GwenH
  T19PE2 openvpn? bozko 0 5,341 10-11-2020 11:43 AM
Last Post: bozko
  how to connect yealink T23G to mikrotik openvpn server m.taghavi 4 14,901 10-11-2020 11:31 AM
Last Post: bozko

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication