New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
BUG?:3CXPhone CTI triggers auto answer on second call when parking 1st
Author Message
tsukraw Offline
Member
***

Posts: 142
Joined: Jan 2014
Reputation: 3
Post: #22
RE: BUG?:3CXPhone CTI triggers auto answer on second call when parking 1st
bsanders
On your 3CX server go to C:\ProgramData\3CX\Data\Http\Interface\MyPhone
There is a fill called cti_template.xml
Right click and edit it.
Look for this line. (Be sure you find the one for with the T4x phones....
<supportedmodels>
<ua>SIP-T41P</ua>
<ua>SIP-T42G</ua>
<ua>SIP-T46G</ua>
<ua>SIP-T48G</ua>
</supportedmodels>

<cticommands delim=";">
<option value="make_call">http://%%deskphone_useraccount%%:%%deskphone_password%%@%%desktopphone_ipaddress%%/servlet?key=%%dialled_number%%;ENTER</option>
<option value="answer_call">http://%%deskphone_useraccount%%:%%deskphone_password%%@%%desktopphone_ipaddress%%/servlet?key=OK</option>

Take the line for answer_call and delete the URL address.
SO it should look like this.
<cticommands delim=";">
<option value="make_call">http://%%deskphone_useraccount%%:%%deskphone_password%%@%%desktopphone_ipaddress%%/servlet?key=%%dialled_number%%;ENTER</option>
<option value="answer_call"></option>

This will prevent CTI from sending the OK command to the phone triggering an answer. The side effect is that it will no longer trigger an answer in any state with CTI. Normally not a issue since not a lot of people use CTI to answer the phone but they do use CTI to dial and transfer.

Does that help?
Also note if you apply this work around if you do a SP or version upgrade you might have to reapply.
02-02-2015 05:14 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
RE: BUG?:3CXPhone CTI triggers auto answer on second call when parking 1st - tsukraw - 02-02-2015 05:14 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Sad New 48 G but call quality is poor vegemite 3 2,390 06-07-2016 02:32 PM
Last Post: Yealink_Karl
  T42g Call Log issue David_Bremek 3 3,224 12-04-2015 01:57 AM
Last Post: B-C
  How to stop auto provision on T48? MarioG 4 5,054 06-16-2015 11:50 PM
Last Post: Yealink_James
  TCP + Call Park DSSKey Failure Bryan Nelson 2 2,096 05-21-2015 12:02 AM
Last Post: Bryan Nelson
  LED blink when missed call? csani 2 2,532 02-06-2015 10:39 AM
Last Post: Yealink_James
  Can't hear self on call DavidAUM 1 2,709 02-03-2015 04:23 AM
Last Post: ModCraig
  Bug? Attended call transfer speedy 8 5,177 01-29-2015 04:10 PM
Last Post: speedy
  Auto Provision Url zamsler 0 1,983 01-06-2015 01:05 AM
Last Post: zamsler
  Anonymous call configuration (local or server) NOS_Support 7 5,177 12-09-2014 07:50 AM
Last Post: David_Bremek

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication