New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HTTPS/SSL Error
Author Message
navok Offline
Junior Member
**

Posts: 5
Joined: Apr 2015
Reputation: 0
Post: #14
RE: HTTPS/SSL Error
Hi! I downgraded my certificates to SHA1 and received the following error with option "CommonName Validation" activated:
Apr 16 11:24:37 SIP [239]: SDL <6+info > [000] tls_connect: remote certificate: subject:/serialNumber=Qsdfsdfsdfsdf0B4YG5bOGJak/OU=GT01975439/OU=See http://www.geotrust.com/resources/cps ©15/OU=Domain Control Validated - QuickSSL® Premium/CN=example.com
Apr 16 11:24:37 SIP [239]: SDL <6+info > [000] tls_connect: remote certificate: issuer: /C=US/O=GeoTrust Inc./OU=Domain Validated SSL/CN=GeoTrust DV SSL CA
Apr 16 11:24:37 SIP [239]: SDL <3+error > [000] Common name and subject alt name doesn't match host name
Apr 16 11:24:38 SIP [239]: SDL <5+notice> [000] common_name:example.com subject_alt_name:
Apr 16 11:24:38 SIP [239]: SDL <6+info > [000] Message sent: (to dest=10.0.0.29:5061)

Domain name and IP addresses I changed in this log due to security reasons.
If I disable this option "CommonName Validation" everything goes OK.
It looks like phone trying to verify, if common name AND subject name in certificate equalent hostname, then it works OK, if this pair doesn't equalent to hostname, then it give error. But in our certificate there are no Subject name, because it is Quick SSL (not Quick SSL Premium). Can we change algorithm so, that phone will compare common name in certificate and hostname (without subject name verification) ?
(This post was last modified: 04-16-2015 07:46 PM by navok.)
04-16-2015 07:16 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
HTTPS/SSL Error - nickcoons - 09-17-2014, 03:22 PM
RE: HTTPS/SSL Error - Lucas1 - 09-19-2014, 06:40 PM
RE: HTTPS/SSL Error - bascheew - 10-17-2014, 05:29 AM
RE: HTTPS/SSL Error - nickcoons - 10-24-2014, 08:31 AM
RE: HTTPS/SSL Error - Lucas1 - 11-10-2014, 10:49 AM
RE: HTTPS/SSL Error - nickcoons - 11-10-2014, 12:01 PM
RE: HTTPS/SSL Error - jvanveen - 02-12-2015, 06:46 PM
RE: HTTPS/SSL Error - bugmenot - 03-13-2015, 03:55 AM
RE: HTTPS/SSL Error - James_Yealink - 03-13-2015, 09:39 AM
RE: HTTPS/SSL Error - navok - 04-09-2015, 09:49 PM
RE: HTTPS/SSL Error - James_Yealink - 04-09-2015, 11:15 PM
RE: HTTPS/SSL Error - navok - 04-10-2015, 02:32 PM
RE: HTTPS/SSL Error - James_Yealink - 04-10-2015, 10:12 PM
RE: HTTPS/SSL Error - navok - 04-16-2015 07:16 PM
RE: HTTPS/SSL Error - navok - 04-27-2015, 11:22 PM
RE: HTTPS/SSL Error - James_Yealink - 05-05-2015, 03:05 PM
RE: HTTPS/SSL Error - navok - 05-05-2015, 10:49 PM
RE: HTTPS/SSL Error - James_Yealink - 05-06-2015, 12:10 AM
RE: HTTPS/SSL Error - Novum Networks - 02-28-2016, 10:17 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  RPS API - Authentication Error jrmende5 3 437 01-06-2020 02:35 PM
Last Post: bmueller
  Autoprovisionong T4xS v83 error gasper_s 2 1,346 11-05-2018 10:25 AM
Last Post: gasper_s
  About HTTPS certificates and trust TrK 8 5,038 06-05-2018 02:14 AM
Last Post: Travis_Yealink
  HTTPS Letsencrypt T48S 66.82.0.20 vs 66.83.0.30 Jacques14623 1 1,371 05-09-2018 02:00 AM
Last Post: Travis_Yealink
  T32G Auto provisioning error with encryption Mike89 0 1,347 09-18-2017 12:47 AM
Last Post: Mike89
  HTTPS Certificates TomJagustin 2 5,935 10-27-2016 04:56 PM
Last Post: jondaley
  Upgrade firmware error from tftp boot server guillosur 1 3,322 05-05-2016 06:18 AM
Last Post: Karl_Yealink
  3CX/T4X not provisioning via HTTPS jasonsomers 1 4,613 10-27-2015 11:27 PM
Last Post: James_Yealink
  Incorrect File Format error on call send, receive or end call morrism 4 6,305 10-06-2015 07:37 AM
Last Post: morrism
  Auto Provisioning error AndyInNYC 1 5,888 09-10-2014 10:19 AM
Last Post: Wilson_Yealink

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication