[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Action URL does not work
Author Message
brickman Offline
Junior Member

Posts: 1
Joined: Jul 2020
Reputation: 0
Post: #3
RE: Action URL does not work
(09-13-2016 03:14 PM)danield Wrote:  Hi, I tried to test with Action URL, with a T48G. But the phone doesn't send something the website. Firmware Version is
Into Remote Controll - Action URI Server IP i tried "any", "" and "". Onto my mac I started a web server which is listening at When i type the address into my browser, I can see a request into terminal of my mac.

But when I save into Action URL the URL, nothings happens. It looks like the phone doesn't call the URL.

What can I do?

Thanks for help.

I know its a bit old but maybe this can help someone else running into this issue. is the same as localhost it points to its self. So if you put into the phone your not pointing the phone to your server but instead pointing the phone back to its self.

If your on windows 10 hit start button then type "cmd" and hit enter to open command prompt. Then type in ipconfig and hit enter. You should see IPv4 Address in that list and next to it should be a number like 192.168.1.### (numbers starting with 192.168.###.### or 10.0.0.###)

If you want to point the phone to a server that is not in the same network switch most people setup POE phones on a seperate network for extra security. Then you'll probably gonna want to use the external IP that is different from that server's 192.... address. search Duckduckgo or google for "whats my ip" from the server if you can as that would propably be the easiest way. then that address is what u put in the phone to point to the server (tho you have to have that port open to the internet then)

Example Incoming Call:$callerID&local=$local&remote=$remote&action=ringing

Also if your looking for more info on what variables work in the URL I found this gude: http://support.yealink.com/forward2downl...q5YFr0lg==

Just incase that link ever is broken I found that on CP920 Firmware&Documents then scroll down to User & Administrator the file title was:
User & Administrator
Yealink SIP-T2 Series T4 Series T5 Series CP920 IP Phones Administrator Guide V85.1.pdf ( Look to Page 465 )

I also attached a screenshot too. I hope that will help my fellow programmers out.

Attached File(s) Thumbnail(s)
(This post was last modified: 07-31-2020 09:11 PM by brickman.)
07-31-2020 09:00 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
Action URL does not work - danield - 09-13-2016, 03:14 PM
RE: Action URL does not work - brickman - 07-31-2020 09:00 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  BLF no work in Unify OpenScape Business marioruiz_2811 4 12,232 05-22-2019 02:52 PM
Last Post: turiatel
  Delayed Action URL call MaartenBode 2 9,928 12-01-2017 09:21 AM
Last Post: AdamNTX
  cannot get forwarding to work p2xt 2 8,243 11-07-2017 10:54 AM
Last Post: p2xt
  VPN Offline allow phone to work Clair 1 7,816 08-04-2017 09:31 PM
Last Post: jolouis
  Action URL does not work danield 0 5,216 09-13-2016 03:12 PM
Last Post: danield
  Action URL with forwarded Calls AndreasS 0 4,978 08-18-2016 04:54 PM
Last Post: AndreasS
  Daylight Saving Time endTime don't work as expected amvalente 4 14,245 04-18-2016 08:26 PM
Last Post: grupocodesi
  Action URL - Incoming Call Futureweb 4 20,194 01-22-2016 03:11 AM
Last Post: Karl_Yealink
  Local DHCP doesnt work when OpenVPN is enabled davids@btni.co.uk 3 11,810 11-19-2015 10:22 AM
Last Post: LandonL
  Usernames and Passwords don't work tdhfox21 1 7,461 11-11-2015 06:30 AM
Last Post: rjdefusco

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication