[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't Factory Reset T22P
Author Message
SimonH Offline
Junior Member

Posts: 1
Joined: Aug 2014
Reputation: 0
Post: #1
Can't Factory Reset T22P
I've had a T22P plonked on my desk to configure for a user. It came from an ex customer some time ago when they closed down, we have no idea how installed it, what the admin password might be, yada yada yada. I do have a number of other Yealink phones (mostly T22, one T26 IIRC) already setup with centralised provisioning etc - just this one I can't "deprogram".

Seems from the manual and many forum posts that holding the OK button down for 10s should give me a factory reset prompt. It doesn't - press the button and the status page comes up, but nothing changes after 10s.

Downloaded the document at http://www.yealink.com/Upload/document/F...61166.pdf, downloaded the recovery package, and followed the instructions to "long press the Speaker button as soon as you power on the phone" which I assume means press and hold the button with a speaker symbol on it. Tried all combinations of press and hold, press and hold for a while then release, press before powering on and shortly after powering on. Nothing happens - I suspect the firmware is too old, the status page says it's got while the doc says it needs min x.41.x.x.

So apart from introducing it to the business end of Mr Hammer Big Grin, is there any other way to deal with it ?
08-06-2014 09:48 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
Can't Factory Reset T22P - SimonH - 08-06-2014 09:48 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  [Solved] Correct password don't work anymore in SIP-T22P ip phones frog.tech 1 7,836 01-27-2021 07:45 PM
Last Post: lsk
  Used T23G, can't factory reset, can't update MonkeySeeMonkeyDo 3 10,169 05-19-2020 07:19 PM
Last Post: Yisroel_MongoTEL
  T22P Action URI ATrans and BTrans not working? DaveThompson 2 11,556 09-10-2019 10:47 AM
Last Post: DaveThompson
  T22P Stuck on FW justingoldberg 0 4,194 08-16-2019 01:19 PM
Last Post: justingoldberg
  T22P DSSKey linekey labels andcza 2 9,347 05-10-2018 06:02 AM
Last Post: andcza
  T22p does not get IP, and does not access the web interface even by manually config jason.luka 5 12,456 04-18-2018 01:29 AM
Last Post: anonymous1701457387898
  T22P -0 3CX firmware web server fails preterion 1 8,008 04-17-2018 02:35 PM
Last Post: will3
  SIP T22P Problem liamretrams 2 10,377 06-01-2017 11:22 AM
Last Post: wcolato
  T20 bought at second hand store. Unable to reset it. Jeff771 6 16,107 05-05-2017 12:41 PM
Last Post: Jeff771
  T22P push xml v61 version Qwerty 0 4,179 12-05-2016 11:02 AM
Last Post: Qwerty

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication