[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 1 Votes - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T48G + EXP40 - Cant configure EXP40 using XML Objects
Author Message
JohnM72 Offline
Junior Member
**

Posts: 3
Joined: May 2016
Reputation: 0
Post: #1
T48G + EXP40 - Cant configure EXP40 using XML Objects
Hi

I have a T48G running latest code (35.80.0.125) with an EXP40 connected.
My PBX application pushes config information down to the phone using XML Configuration Objects within SIP Notify Messages.
Config settings for the phone Line Keys are always successful. However Config settings for the EXP40 keys do not work.

For example, to set LineKey 1 on the phone as an XML broswer Key, the following is sent:

<?xml version="1.0" encoding="UTF-8"?>
<IPPhoneConfiguration Beep="no" setType="config">
<Item>linekey.1.type = 27</Item>
<Item>linekey.1.label = DND</Item>
<Item>linekey.1.value = https://192.168.1.197/pbx-1/xhtml.cgi?de...;/Item>
</IPPhoneConfiguration>

This is always successful.

To disable the Key, the following is sent:

<?xml version="1.0" encoding="UTF-8"?>
<IPPhoneConfiguration Beep="no" setType="config">
<Item>linekey.1.type = 0</Item>
</IPPhoneConfiguration>

This is also always successful.

To Set the first key on the EXP40 as an XML browser key, the following is sent:

<?xml version="1.0" encoding="UTF-8"?>
<IPPhoneConfiguration Beep="no" setType="config">
<Item>expansion_module.1.key.1.type = 27</Item>
<Item>expansion_module.1.key.1.label = DND</Item>
<Item>expansion_module.1.key.1.value = https://192.168.1.197/pbx-1/xhtml.cgi?de...;/Item>
</IPPhoneConfiguration>

This occasionally works. Sometimes even the label may be changed but not the value.

To disable the first key on the EXP40, the following is sent:

<?xml version="1.0" encoding="UTF-8"?>
<IPPhoneConfiguration Beep="no" setType="config">
<Item>expansion_module.1.key.1.type = 0</Item>
</IPPhoneConfiguration>

This never works.

I have seen the same results with the EXP40 connected to a T46G.
I can also provide detailed logs from the phone showing that in all cases, the SIP Notify message is correctly received and responded to with an OK.

Any help would be much appreciated!
07-15-2016 09:18 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
T48G + EXP40 - Cant configure EXP40 using XML Objects - JohnM72 - 07-15-2016 09:18 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  How to configure T27G TRAN key in Call Fwd Custom mode ? oliv 0 551 04-07-2020 02:20 PM
Last Post: oliv
  Using Push XML to configure DSS Keys Rob! 2 2,753 02-06-2018 03:11 AM
Last Post: Aishion_Yealink
  Call Park Mode transfer on T48G jasonblewis 2 4,147 11-09-2017 01:26 AM
Last Post: Aishion_Yealink
  T48G not connecting to Skype Lisa H 0 1,636 10-16-2017 03:17 AM
Last Post: Lisa H
Bug T46g & T48G RADIUS 802.1x and SHA256 Bigmac 22 23,741 08-13-2017 07:54 PM
Last Post: MiKeDaDoC
  can't setup openvpn with t48g zzz 8 11,142 07-18-2017 09:04 AM
Last Post: sj
  T48G - busy tone for a second incomming call Dirk 8 9,039 01-17-2017 05:36 PM
Last Post: complex1
  T46G with exp40 Paulo Batista 2 4,158 11-06-2016 01:57 AM
Last Post: ModCraig
  T48G BLF triggers display brightness MaxHeu 4 5,204 10-25-2016 09:23 PM
Last Post: MaxHeu
  Configure call forwarding Seb 2 4,974 10-19-2016 12:16 AM
Last Post: yeabee

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication