[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T20P/T26P audio problem on call transfer
Author Message
carlos.franco Offline
Junior Member

Posts: 8
Joined: May 2014
Reputation: 0
Post: #1
T20P/T26P audio problem on call transfer
Hello all!

I'm having a very tricky problem with yealink phones T20P and T26P (almost all my more than 2000 terminals suffer with this problem). The scenario is: phone A calls phone B; Phone B answers the call and transfers it to phone C (no matter if it is an attended or blind transfer). Then the audio from phone A user is completely unperceptive on phone C (choppy and metallic like if there is a problem on RTP synchronism). Audio from phone C to phone A is good.
Additional notes:
1. I tried with and without a SIP proxy. The behavior is the same;
2. Attended transfer is made through pressing * during the call. DTMF are sent to the sip server out of band (RFC 2833);
3. The problem don’t happen if I use G711 codec;
4. When using SIP proxy I tried to capture outgoing RTP packet from the SIP proxy for an entire call. Then I reassembled RTP packet payload for each feed (from proxy to phone A and the other to phone C) onto 2 audio files. Both audio are good, no packet missing and perfectly audible. So the audio exits the proxy in apparently good conditions.
5. I tried several versions of firmware but the behavior is always the same;
6. I googled about the problem and found someone complaining the same but no solution were provided. Someone hinted about problems in the RTP packets timestamp…

If someone have the same problem, is it possible to share his/her findings or maybe point for the solution? I’m pretty sure that it should be something messing with RTP reassembling on the yealink (maybe the timestamp problem I found on google can give an explanation) because I have other phone brands (grandstream and Aastra) that are configured exactly in the same way yealink are and they don’t experience this problem.
Thanks for any clue you can give me.

Carlos Franco
05-08-2014 06:52 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
T20P/T26P audio problem on call transfer - carlos.franco - 05-08-2014 06:52 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Possible upgrade T26P Zdenda_Enter 3 2,636 07-12-2022 04:23 PM
Last Post: Zdenda_Enter
  T26P failed to register with TLS transport tvt 0 2,596 10-29-2021 02:58 PM
Last Post: tvt
  Lost my configuration trying to fix a static audio problem nestman 0 3,214 06-22-2021 06:33 AM
Last Post: nestman
  Multiline Transfer T29G pedro_indy 0 4,618 11-27-2020 01:11 AM
Last Post: pedro_indy
  T26P Can not upgrade firmware martien.poels@bank2loyalty.com 2 8,096 09-21-2020 05:16 PM
Last Post: complex1
  T28P foward call doesn´t work with Tato 4 9,726 09-14-2020 03:49 PM
Last Post: complex1
  T28P LDAP Problem oguzhan 1 6,733 06-10-2020 01:14 PM
Last Post: beldimon
  "On hook" event problem Rafal 6 14,266 03-26-2020 03:35 AM
Last Post: Normfred
  Attended transfer not working T29G chysky@slany.cz 1 5,321 02-11-2020 02:48 PM
Last Post: chysky@slany.cz
  How to change voice when busy, waiting and other.. T20P marin 0 3,566 04-11-2019 12:53 PM
Last Post: marin

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication