New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
T22P Action URI ATrans and BTrans not working?
Author Message
DaveThompson Offline
Junior Member
**

Posts: 2
Joined: Jun 2016
Reputation: 0
Post: #1
T22P Action URI ATrans and BTrans not working?
Hi,

I have been trying to get the remote calls for Transfers and Conference working with the T22P.

I am receiving http 404 responses when calling through to the ATrans and BTrans Action URI's, full form of these urls:
http://192.168.20.236/cgi-bin/ConfigManA...1628564670
http://192.168.20.236/cgi-bin/ConfigManA...1628564670

I have also tried:
http://192.168.20.236/servlet?ATrans=01628564670
http://192.168.20.236/servlet?BTrans=01628564670

All of which return a 404.

from the documentation I believe that this is the correct format, as I can get the CALLEND, and number=xxx&outgoing_uri=y forms working. I have tried this while both on and off calls, though I would expect it not to work while off a call.

I am able to successfully call through and do remote key presses, so I don't believe it's a security setting.

Does anyone know if this functionality works in this model of phone?

As an side, it appears the softkeys work, though it's not an ideal solution as getting the correct events to accept the transfer doesn't work:
http://192.168.20.236/cgi-bin/ConfigManA...F_TRANSFER
http://192.168.20.236/cgi-bin/ConfigManA...28564670OK
-- warm transfer at this point
(gives an established event)
http://192.168.20.236/cgi-bin/ConfigManA...F_TRANSFER
-- fully complete transfer (needs to be after answer)
(gives events in order: Transfer, Terminated, Attended Transfer)


Thanks in advance,
Dave
06-17-2016 10:20 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
T22P Action URI ATrans and BTrans not working? - DaveThompson - 06-17-2016 10:20 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T22P Stuck on justingoldberg 0 72 08-16-2019 01:19 PM
Last Post: justingoldberg
  Yealink T27G Not Working With 802.1x Auth After 3cx v14 to v15.5 Upgrade KM Tire IT Support 1 922 10-18-2018 05:06 PM
Last Post: KM Tire IT Support
  T22P DSSKey linekey labels andcza 2 1,856 05-10-2018 06:02 AM
Last Post: andcza
  T22p does not get IP, and does not access the web interface even by manually config jason.luka 5 2,268 04-18-2018 01:29 AM
Last Post: Samuel_Yealink
  T22P -0 3CX firmware web server fails preterion 1 1,509 04-17-2018 02:35 PM
Last Post: will3
  Call Queue not working with the Grandstream UCM6202 ttran 8 6,297 03-04-2018 06:42 PM
Last Post: Adnanka
  SIP T22P Problem liamretrams 2 3,412 06-01-2017 11:22 AM
Last Post: wcolato
  Call Forward on T21P E2 not working gradash 8 6,685 05-23-2017 09:44 PM
Last Post: jolouis
  Call Queue not working with the Grandstream UCM6202 ttran 0 1,800 05-04-2017 05:48 PM
Last Post: ttran
  T22P push xml v61 version Qwerty 0 1,213 12-05-2016 11:02 AM
Last Post: Qwerty

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication