[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
OpenVPN connection to Elastix failing
Author Message
l4telcom Offline
Junior Member

Posts: 6
Joined: Dec 2013
Reputation: 0
Post: #6
RE: OpenVPN connection to Elastix failing
Ok, so when I was sending you the crts privately, I did notice that they said Signature Algorithm: sha256WithRSAEncryption. I found that the way to change the Signature Algorithm was to modify the openssl-#.#.#.cnf files as follows:
under the [ CA_default ] header change 'default_md = sha256' to 'default_md = sha1'
and under the [ req ] header change 'default_md = sha256' to 'default_md = sha1'

After making those changes, I created all new keys, and now they show Signature Algorithm: sha1WithRSAEncryption. After recreating my tar file to upload to the phone, I was able to get the phone to connect to the VPN. I can register up an extension against the Elastix PBX using the VPN IP, but whenever I place test calls, I get a serious delay with audio going from the VoIP phone to the outside call as well as sever audio quality issues. There is no delay or quality issues with the audio from the outside call to the VoIP phone. I have tried adding in the
but that doesn't seem to resolve the problem. If I try to register the extension by using the public ip of the PBX, I do not get any audio from the to the VoIP phone outside call.
03-01-2014 01:47 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: OpenVPN connection to Elastix failing - l4telcom - 03-01-2014 01:47 AM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  DHCP not working on T26P when OpenVPN is enabled. LandonL 11 25,654 05-12-2021 10:46 AM
Last Post: 1sae
  Solved Openvpn.tar creating the right size file compsos 3 4,466 08-20-2020 06:49 AM
Last Post: complex1
  OpenVPN and QoS/TOS roelvanmeer 0 2,895 02-19-2019 09:27 AM
Last Post: roelvanmeer
  OpenVPN Timeout connecting p2xt 3 6,524 07-13-2018 07:37 PM
Last Post: jolouis
  Network Directory gives Connection Error TelNet Worldwide_Support 1 4,343 09-15-2017 02:59 AM
Last Post: Lucia_Yealink
  openvpn w52p setup rafael 4 14,200 08-10-2017 02:03 PM
Last Post: indicato
  can't setup openvpn with t48g zzz 8 17,164 07-18-2017 09:04 AM
Last Post: sj
  BLF Trunk Monitor Elastix Ricardo111 1 4,678 12-30-2016 10:13 AM
Last Post: Jensen_Yealink
  Inconditional Forward Failing. warawara 1 4,692 10-01-2016 01:06 AM
Last Post: Kevin_Yealink
  OpenVPN in T27P arcsistemes 1 5,450 07-13-2016 04:50 PM
Last Post: Klaus_Yealink

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication