[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.

Post Reply 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
bricked w52p - need recovery files
Author Message
havellab Offline
Junior Member

Posts: 2
Joined: Feb 2016
Reputation: 0
Post: #3
RE: bricked w52p - need recovery files
Hi Frank,

thanks for the hints. Unfortunately I cannot seem to get this station work again.

The factory reset does not work as much as I can tell.

* When I plug in power, only the lowest LED indicating power goes on. Network wise nothing happens, the station does not produce a single packet

* When I plug in and push the button before powering up, and holding, all LEDs go on in sequence, and the station sends out ARP requests from to

* If I present a host at the station wants to connect via TFTP

* If I present a TFTP server at it wants to download W5X.bin and W5X.rfs

* If I present those two files, it downloads them ok, then nothing happens anymore. The station does not request the W52P.bin.

The factory reset procedure provided above leaves me with the same behaviour: after powering it up again only the power LED goes on, no network, nothing.

Now I have seen multiple posts on the forum with similar problems, none have brought me any further. And actually here is part of my problem.

I cannot seem to be able to download the .rfs and .bin files from anywhere on the website. All I can find are either

* links to an FTP with an yealinkftp user and pw that do not work anymore
* links to an FTP with a login from an employee Cindy that gave out her login on the forum, but does not work anymore
* links to an FTP with a session-id kinda thing that worked only for one user
* posts from yealink folks sending the files via private messages to users
* links to users offering .rfs and .bin files hosted on Google drive or some other service I do not want to use and trust

Now I really don't get why those files are not just provided along the firmware in the download section. Wouldn't that be the proper way? Also, the recovery manual is something not readily available either. Not sure what the reason for this is. I have now tried to work with those files I found somewhere on the internet. They dont work, or maybe the phone is bricked -- see above. I cannot really verify it as I cannot even verify I have the correct files.

Happy about any input here, I was quite happy with the phone actually.

02-22-2016 05:56 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 

Messages In This Thread
RE: bricked w52p - need recovery files - havellab - 02-22-2016 05:56 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  W52P not working after change of broadband supplier Jasibansel 1 1,356 01-22-2024 07:15 PM
Last Post: complex1
Sad W52P not picking up IP Burkni 4 5,477 09-19-2023 06:22 PM
Last Post: Burkni
  W56H with W52P Base dmvcomms 7 9,659 03-06-2023 04:39 PM
Last Post: poznaniak
  W73H handset with W52P problem reboot Paco Brufal 2 4,006 03-03-2023 01:21 AM
Last Post: nolto
  W52P Repeater RT10/rt20/RT30 schnell-yealink 3 9,670 04-20-2022 10:17 PM
Last Post: complex1
  Were I can get proper bin and rfs files for FW Alex_RC 10 28,991 09-29-2021 03:38 AM
Last Post: complex1
  W52P Firmware upgrade aunijaffer@gmail.com 5 13,853 09-07-2021 11:42 PM
Last Post: complex1
  W52P 2 handsets DAZZLING 1 7,513 06-01-2021 09:55 PM
Last Post: complex1
  W52P Openvpn with mikrotik info@quantiss.com 4 18,367 04-11-2021 06:25 AM
Last Post: Harms_Kubiak
  Is there no call history in web management panel in W52P? poznaniak 1 8,109 08-10-2020 12:49 PM
Last Post: complex1

Forum Jump:

User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication