[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cant dial Emergency 911 on v81 Firmware...??
Author Message
Spencer06 Offline
Banned

Posts: 3
Joined: Mar 2017
Post: #4
RE: Cant dial Emergency 911 on v81 Firmware...??
I ran into this problem too and it caused a lot of frustration. It seems to be a bug in the firmware. I think it is trying to use the new emergency dialing feature even if you didn't configure it, and it wants to use port 5060. We use port 5061 for internal phones, so it was trying to send the INVITE on the wrong port (and PJSIP, on port 5060, says "no matching endpoint found"). I had to set the following options in the config files, then 911 dialing worked:


dialplan.emergency.server.1.address = (your SIP server IP)
dialplan.emergency.server.1.port = (port number, 5061 in our case)
dialplan.emergency.server.1.transport_type = 0 (specifies UDP - not sure if this is needed or not)
dialplan.emergency.1.server_priority = 1,2,3


Hope that helps someone in the future. Yealink needs to fix this. If 911 is dialed but emergency dialing is not configured, it needs to go to the primary SIP server the phone is registered to!!

(01-28-2017 12:41 AM)Jessy Wrote:  Hello all,



I just spent 3 days troubleshooting an issue:



Sangoma PBXact 60 PBX Server(latest updates)



I just installed a new phone system and deployed the v81 firmware to all the T46G phones. After installation I made a test call to 911 to make sure the E911 was reading back correctly and it would not dial. The arrows just kept scrolling across the screen.



Deleted all the routes and rebuilt them and it still would not dial. I called my phone provider and they confirmed they are not even receiving the SIP request. Began troubleshooting and looking into the logs and this is what shows when trying to dial 911:

[2017-01-27 16:28:03] NOTICE[21337] res_pjsip/pjsip_distributor.c: Request 'INVITE' from '"103" <sip:103@10.15.20.8>' failed for '10.15.20.174:5160' (callid: 0_1228372804@10.15.20.174) - No matching endpoint found

[2017-01-27 16:28:03] NOTICE[21337] res_pjsip/pjsip_distributor.c: Request 'INVITE' from '"103" <sip:103@10.15.20.8>' failed for '10.15.20.174:5160' (callid: 0_1228372804@10.15.20.174) - Failed to authenticate



Called Sangoma and they also troubleshot with me very confused as to what is happening. After working for 1 1/2 hours with them we gave up as the tech support wanted to look farther into the issue.



I then came back to my office on a different PBX server and tried to dial 911 on my phone also running the latest firmware v81. No dice. I could NOT dial 911 yet again. I walked over to all the other phones running v80 and it worked with no issues.



I then downgraded my phone and now i can again dial 911. I also want to point out that we use Chan_SIP not PJSIP so i am not sure why dialing 911 is trying to run a PJSIP command, this is why the phone system rejects it and the phone just sits there with arrows across the screen trying to dial out.



Please let me know whats happening and anyone else running v81 using FreePBX/PBXact please try and make sure it works or doesn't.
03-20-2017 02:39 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Cant dial Emergency 911 on v81 Firmware...?? - Spencer06 - 03-20-2017 02:39 PM

Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Yealink T48s Firmware update failed dangmoss 2 2,730 02-19-2022 03:09 AM
Last Post: dangmoss
  Problem Change Firmware T48s from SFB to SIP Lars Maschke 2 2,825 01-14-2022 10:22 AM
Last Post: kumagera
  Need to remove custom Fonality firmware 1CCT 16 27,358 05-03-2021 08:24 PM
Last Post: kmconklin
  SIP-T46s Bricked after latest firmware update. daniel.broome 2 5,026 04-27-2021 11:39 AM
Last Post: daniel.broome
  OEM Firmware change NotKnown 1 3,391 04-14-2021 07:41 PM
Last Post: complex1
  documentation and firmware T43u jmooo 0 2,946 02-18-2021 02:23 AM
Last Post: jmooo
  Avoid Firmware V85 at all costs! lukeescude 0 2,158 02-13-2021 12:06 AM
Last Post: lukeescude
Bug Yealink T46G wont turn on after firmware update mike702 1 3,741 02-02-2021 08:21 PM
Last Post: complex1
  Cannot Downgrade Yealink SIP-T43U firmware YeaVictor 1 4,884 12-17-2020 01:12 AM
Last Post: YeaVictor
  Creating Pause in Speed Dial on T42S tcodispot 1 2,924 12-16-2020 05:47 AM
Last Post: Yisroel_MongoTEL

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication