[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RPID headers problems
Author Message
ezubillaga Offline
Junior Member
**

Posts: 3
Joined: Aug 2013
Reputation: 0
Post: #1
RPID headers problems
I'm currently having some issues with the RPID headers on SIP messages and a T26P running firmware version 6.70.0.141. We use Asterisk version 1.8.19.1 as our IP-PBX.

We are trying to display the name and number of the dialed facility in the phone based on the RPID header we sent during the call setup. Our voicemail facility is accessed dialing *97 and if we try to set the RPID header to send "Voicemail *97" <sip:*97@192.168.245.1>" the message ('Voicemail *97') is not displayed in the phone. If we change the RPID SIP part to something else, for example "Voicemail *97" <sip:*99@192.168.245.1>" everything works fine. I have done many tests with different options and strings an my conclusion is that the '<sip:XXX@' part of the RPID header have to be different than the number dialed or otherwise the phone will ignore the RPID header.

Here are a couple of examples of the complete headers:

- Don't work:
Remote-Party-ID: "Voicemail *97" <sip:*97@192.168.245.1>;party=called;privacy=off;screen=no

- Work as expected:
Remote-Party-ID: "Voicemail *97" <sip:*99@192.168.245.1>;party=called;privacy=off;screen=no

We have used many other phones from other vendors and have always been able to modify the display on the phones based on the RPID even if the number dialed is the same as the one placed in the header.

Do you think this could be something you guys can check and see if can be fixed in any way?

Thanks in advance!
(This post was last modified: 08-09-2013 08:32 PM by ezubillaga.)
08-09-2013 08:31 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Yealink Support Offline
Administrator
*******

Posts: 2,684
Joined: Dec 2012
Reputation: 24
Post: #2
RE: RPID headers problems
Hi ezubillaga,
So if you use "Remote-Party-ID: "Voicemail *97" <sip:*97@192.168.245.1>;party=called;privacy=off;screen=no", when you dial *97, the phone can only display "*97", but can't display "Voicemail *97", right?

Could you provide PCAP trace, syslog(level 6) and config.bin file to us, so we can analyze?
Before you export the syslog, please set log level as 6, and reboot the phone, then click Start,and reproduce the issue, then click Stop,and export the trace, syslog, config,bin to us.
(About where to export these files, please refer to attached screenshot.)
These three files are very important for us, hope you can kindly understand.
Thanks.


Attached File(s) Thumbnail(s)
   
08-13-2013 02:51 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
ezubillaga Offline
Junior Member
**

Posts: 3
Joined: Aug 2013
Reputation: 0
Post: #3
RE: RPID headers problems
Correct, using "Remote-Party-ID: "Voicemail *97" <sip:*97@192.168.245.1>;party=called;privacy=off;screen=no" cause the phone display "*97"

Attached config.bin, syslog.tar and 2 pcap files, one using "Remote-Party-ID: "Voicemail *97" <sip:*97@192.168.245.1>;party=called;privacy=off;screen=no" and other using "Remote-Party-ID: "Voicemail *97" <sip:*98@192.168.245.1>;party=called;privacy=off;screen=no" which causes the display change as expected.

Regards,

Erasmo


Attached File(s)
.pcap  10:45am - not working - 6.70.0.141_10-45-27.pcap (Size: 79.5 KB / Downloads: 2)
.pcap  10:46am - working - 6.70.0.141_10-46-27.pcap (Size: 67.53 KB / Downloads: 1)
.tar  syslog.tar (Size: 308.5 KB / Downloads: 2)
.zip  config.zip (Size: 17.56 KB / Downloads: 2)
08-13-2013 10:55 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Yealink Support Offline
Administrator
*******

Posts: 2,684
Joined: Dec 2012
Reputation: 24
Post: #4
RE: RPID headers problems
Thanks Erasmo,
Let me submit to R&D to check, any update will let you know ASAP.
08-14-2013 10:58 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
ezubillaga Offline
Junior Member
**

Posts: 3
Joined: Aug 2013
Reputation: 0
Post: #5
RE: RPID headers problems
Thanks to you. Please let me know if you find anything.
08-14-2013 07:25 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  T19P - PoE problems Ret 0 1,581 05-18-2021 05:10 AM
Last Post: Ret
  Audio problems on phones (t23g i t42s) bob_1921 2 4,050 12-02-2020 04:46 AM
Last Post: bob_1921
  Yealink and Fortigate problems. maquinero 1 6,447 03-10-2016 03:54 AM
Last Post: Karl_Yealink
  Anyone got tips for dealing with echo problems? stefan@nunetworx.com 1 7,845 11-22-2013 11:12 AM
Last Post: Yealink Support
  OpenVPN problems with new firmware T26 V7 alfil2k 1 10,184 03-26-2013 05:18 PM
Last Post: Yealink Support

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication