[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Line LED on/off and color
Author Message
AndyM Offline
Junior Member
**

Posts: 6
Joined: Jul 2015
Reputation: 0
Post: #1
Line LED on/off and color
First, my goal: to use a button to set up/disable an account on the phone and turn the account's LED to red or green depending on the status of the account.

In the developer's documentation using XML Browser, the YealinkIPPhoneExecute tag allows turning a line LED on/off and can also set the color. If this is all I do, it works great.

I am currently setting up two buttons, one to configure an account and one to disable it. If the account is enabled I want that line LED to be green, and if I disable the account I want the line LED to be red. If I also call another XML in the YealinkIPPhoneExecute file, one that uses the YealinkIPPhoneConfiguration tag to either configure an account or remove it, the LED turns on with the specified color briefly and then turns off again once the XML processing is finished. I assume it's due to a refresh that occurs after a script that changes the phone configuration, as pressing the same button again results in the light turning on and staying on (and the same line configuration is applied, so no change occurred there). Pressing the other button changes the line configuration, and I run into the same problem. I have tried changing the order of the commands I call but it does the exact same thing no matter what order they are called in. I also tried including the LED command twice, once before and once after the line calling the second XML, but it didn't change anything. I have included a copy of the XML document to disable the account and turn the LED to red below as an example.
Code:
<?xml version="1.0" encoding="ISO-8859-1"?>
<YealinkIPPhoneExecute Beep = "yes">
<ExecuteItem URI = "Led:LINE3_RED=on"/>
<ExecuteItem URI = "http://server/phone-test-remove.xml"/>
<ExecuteItem URI = "Led:LINE3_RED=on"/>
</YealinkIPPhoneExecute>

Does anyone have any suggestions for how I can both change the configuration and get the line LED to stay lit and the color to change?
07-07-2020 02:40 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Question Download config by command line sadzas 3 2,291 07-29-2019 06:02 AM
Last Post: Paz_Yealink
  Change standard outgoing line on T46G oestersund 1 1,726 12-15-2018 09:58 PM
Last Post: support2
Question Yealink line Disabeling itself krishanm0866 0 2,368 10-07-2016 09:01 AM
Last Post: krishanm0866
  VOIP Yeahlink T28 Line ringtones Dayyan 0 2,300 06-23-2016 07:26 PM
Last Post: Dayyan
  Multi-Line Phones, Line Type and Receiving Simultaneous Calls kmccracken 1 5,210 02-25-2016 05:54 AM
Last Post: Karl_Yealink
  Multiple Line Registration kmccracken 3 6,982 12-17-2015 11:19 AM
Last Post: Karl_Yealink
  T26P Show Incoming number if Line is picked up Tijnie1978 2 3,974 07-08-2015 12:56 PM
Last Post: Tijnie1978
  Shared Line Setup hancocktel 2 5,874 03-17-2015 09:16 PM
Last Post: Flora_Yealink
  Shared Line Appearance option not found sbaig04@yahoo.com 2 5,238 01-06-2015 11:28 PM
Last Post: sbaig04@yahoo.com
  Changing settings with script or command line riaan30 1 3,921 12-09-2014 10:48 PM
Last Post: jolouis

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication