[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Autprovisioning DSS keys won't take...
Author Message
starion Offline
Junior Member
**

Posts: 31
Joined: Apr 2014
Reputation: 0
Post: #1
Autprovisioning DSS keys won't take...
Successfully auto provisioned a T23G phone, but then decided I wanted to switch two of the keys around.

Ever since making the changes to the config files, I cannot get my new key assignments to load into the phone. I am able to make the settings take by using the GUI.

Yes, the files are loading as I can confirm other settings were loaded from the same config files that has the DSS key changes.

I have tried factory resetting the phone and it still does not pull the correct DSS layout.

I've gone around and around with this for an hour now.

Well, I recreated the files from scratch, cut/copy/pasted the stuff back into them, and now they work.

As a side note, I sure would like to know how a text file gets "corrupted". Seriously, I would like to look at it with an editor and see if I can tell what caused the phone to choke so I might be able to "fix" corrupt configs without having to totally re-create it. Anybody ever analyzed this? I've seen several mentions now about this happening.
(This post was last modified: 09-23-2019 11:37 PM by starion.)
09-23-2019 10:56 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
jolouis Offline
Moderator
*****

Posts: 339
Joined: Oct 2013
Reputation: 6
Post: #2
RE: Autprovisioning DSS keys won't take...
Not sure what your actual issue was, but usually we run into this sort of thing when a user makes changes and those changes are not prefixed as "static." in the provisioning files. If you don't have the static nomenclature in there the provisioned settings are lower priority than "user defined" ones, so short of a factory reset there's no way to get them to apply again.

Doesn't sound like that was the case here but wanted to mention it so you were aware in the future.

As far as text files getting corrupted, sure I've seen it happen before. Not a provisioning server but definitely on hard drives that are failing, USB drives that choke, etc. Typically the text file will look visually "almost OK", but some of the characters go funky. Other times characters that are not visually displayable get randomly jammed into spots throughout the file. Open your "clean" copy up against the corrupted one in something like Notepad++ and you should be able find the differences fairly easily.
09-25-2019 07:21 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  Multiple keys for account jwrigh13 2 9,188 07-15-2015 09:59 PM
Last Post: jwrigh13
  T46G - How to "lock" the line keys? tb303 5 17,383 11-24-2014 11:30 PM
Last Post: CWR
  3cx Auto Provision Line Keys as Call Park mdctech 3 16,452 08-21-2014 09:36 AM
Last Post: Yealink Support
  DSS Keys VOIP 1 8,042 10-16-2013 05:37 AM
Last Post: Barnabas
  SOLVED: Cannot set DSS keys for T46G jfmorris 6 27,277 08-01-2013 03:44 PM
Last Post: honey

Forum Jump:


User(s) browsing this thread:

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication