[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Yealink T26 and is not accepting Option 66
Author Message
SimonVolk Offline
Junior Member
**

Posts: 1
Joined: Nov 2017
Reputation: 0
Post: #1
Yealink T26 and is not accepting Option 66
Hi All,

I am experiencing some issues with Yealink devices T26 and T29P in combination with DHCP option 66.
Other models are working fine such as T22 T28P so I think that the server configuration is correct.


Scenario:
During boot process the T26 requests the IP address from the DHCP (isc-dhcp-server), in the response the DHCP sends the TFTP Option 66 to the device (answer displayed below).


The problem is that the T26 does not accept the parameter and it does not starts with auto provisioning. In the GUI the Server URL field is empty.
Does anyone know where is the trick ?
I already tried to change few SW releases but i got always the same result.
Any help will be appreciated.



kubuntu.bootps > 192.168.10.12.bootpc: [udp sum ok] BOOTP/DHCP, Reply, length 300, xid 0x76949562, secs 100, Flags [none] (0x0000)
Your-IP 192.168.10.12
Server-IP kubuntu
Client-Ethernet-Address 00:15:65:21:21:cb (oui Unknown)
Vendor-rfc1048 Extensions
Magic Cookie 0x63825363
DHCP-Message Option 53, length 1: ACK
Server-ID Option 54, length 4: kubuntu
Lease-Time Option 51, length 4: 40114
Subnet-Mask Option 1, length 4: 255.255.255.0
Default-Gateway Option 3, length 4: kubuntu
Domain-Name-Server Option 6, length 4: kubuntu
TFTP Option 66, length 22: "http://10.10.10.10/ps"
END Option 255, length 0
PAD Option 0, length 0, occurs 2


Thanks

Simon
07-23-2018 11:29 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
jolouis Offline
Moderator
*****

Posts: 339
Joined: Oct 2013
Reputation: 6
Post: #2
RE: Yealink T26 and is not accepting Option 66
Check under Settings->Auto Provision and make sure that "DHCP Active" is set to "On". Without that the phone will ignore the DHCP options and not provision using that method.

Alternatively do a complete factory reset of the phone (hold the OK button for 10-15 seconds until prompt on the screen shows up) just to be safe. We have provisioned many T26s back when they were an active product using DHCP/TFTP, so definitely not a problem with the phones in general...
07-23-2018 01:07 PM
Find all posts by this user    like1    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  refurbished yealink, but old provider daniel_md1 0 211 06-22-2024 11:11 PM
Last Post: daniel_md1
  DHCP option 66 or 43 with FTP credentials jakthree 1 1,146 03-08-2024 04:19 AM
Last Post: jakthree
  Yealink T54W Auto Provision not working h.cmc 1 4,390 12-09-2022 08:31 PM
Last Post: complex1
  Configure Yealink Phones autoprov and Action URLS on demand adeo 1 5,725 11-16-2022 10:52 PM
Last Post: bomberyealink
  Yealink Manufacturing CA IFM Ltd 0 2,497 05-27-2022 08:00 AM
Last Post: IFM Ltd
  Yealink T54W - disable wifi from template itops@vivcourt.com 2 6,269 01-25-2022 10:32 AM
Last Post: itops@vivcourt.com
  Yealink CA certificate IgorG 2 9,945 06-11-2021 02:23 PM
Last Post: smuser
  Action url variable $cfg_all not working on Yealink T57W Ivan86 1 7,244 03-19-2021 03:07 PM
Last Post: Ivan86
  Option to override RPS ozimarco 3 9,319 07-14-2020 12:10 PM
Last Post: complex1
  need complete list of yealink rps server IP's for firewall DanH 1 10,465 07-26-2019 07:00 AM
Last Post: anonymous1718628087441

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication