New Forum system requires email address which you used to apply for your account to replace your original username. Password stays the same.Please see this post for more details
http://forum.yealink.com/forum/showthread.php?tid=40344

Yealink Test Club has been officially launched. Please visit post below to get detail information. Come and join us!
http://forum.yealink.com/forum/announcements.php?aid=18

We just had the YMCS online and we are also working on the features plan on the future versions, in this regard we are need to hear your voice about the YMCS.
Please visit : http://forum.yealink.com/forum/showthread.php?tid=42322


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
VLAN bug
Author Message
Kevin3 Offline
Junior Member
**

Posts: 1
Joined: Feb 2018
Reputation: 0
Post: #1
VLAN bug
So network setup is:

VLAN 10 is untagged = 10.0.10.0/23 (for voice)
VLAN 20 is tagged = 172.16.10.0/23 (for data)

Firmware is version 80.0.95 but has been the case since version 70

Screen shots attached.

The internet port on the phone is connected to the network switch and the PC port is connected to the computer.

When the phone reboots, during the initializing period, the phone passes UNTAGGED packets to the PC port, therefore, as the network connection is temporality dropped on reboot, when it is re-established, the computer requests a new DHCP address and since the untagged VLAN 10 packets are being passed, an IP address in the range of 10.0.10.0/23 to the PCs instead of an IP address in the 172.16.10.0/23 range. Once the phone has restarted, the switch in the back of the phone operates as expected only allowing tagged VLAN 20 packets through. So renewing the IP address on the PC again, gives the correct IP address.

While its easy to fix, its quite annoying as every time any of our T42G or T46G are restarted, if there is a PC connected to the phone at that time, then it will get the wrong IP and therefore will not be able to connect to network services anymore.


Attached File(s) Thumbnail(s)
           
02-16-2018 05:37 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  IP Phone acquire untagged VLAN IP instead of tagged VLAN f.pancani 2 2,828 04-21-2018 07:49 AM
Last Post: Johnny88
  my voice vlan can not recieve ip from microsoft dhcp server salar 1 1,927 06-23-2017 06:47 AM
Last Post: Kevin_Yealink
  dhcp vlan option 132 - works without settings visible in UI dywilson 2 4,091 06-22-2017 12:48 PM
Last Post: salar
  VLAN Settings in Yealink ip phones gayan4u 1 2,866 03-31-2016 06:05 AM
Last Post: Karl_Yealink
  T46G IP Phone with cisco 2960 switch VLAN kongi 1 3,701 02-17-2016 11:18 AM
Last Post: Karl_Yealink
  T46G - Voice VLAN - 3cx - HP 4500G switch jholcombe 5 9,944 08-16-2014 11:42 AM
Last Post: Yealink Support
  t46g tagged vlan not working adamw 4 8,248 06-14-2014 10:38 AM
Last Post: Yealink Support
  T26P vlan krb 1 6,404 01-14-2013 04:57 PM
Last Post: Yealink Support

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication