[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
w52P auto provision
Author Message
Chris Barron Offline
Member
***

Posts: 50
Joined: Sep 2015
Reputation: 0
Post: #1
w52P auto provision
Chaps,
we deploy a large number of W52ps and Ive just discovered that our tech's are having to configure the base stations manually because auto provision does not work.
T41's work ok.
firstly the factory default has
auto_provision.pnp_enable =1, which is inappropriate for most business network, rather than domestic deployments.
Using option 66 DHCP pushes the request to the Yealink RPS and the entry there returns the correct provision host according to the logs. However the base station is not updated with the server credentials and the provision fails.
If I enter the provision credentials correctly, URL, username and password - it works ok

I get the following from the logs: (server ip address redacted.)

3 17:17:40 LIBD[509]: DCMN<6+info > Connecting rps.yealink.com:443
Nov 3 17:17:41 LIBD[509]: DCMN<6+info > Connecting IP = 184.106.101.50, Port = 443
Nov 3 17:17:41 LIBD[509]: DCMN<6+info > SSL_connect (read done)
Nov 3 17:17:42 LIBD[509]: DCMN<6+info > SSL_connect (read done)
Nov 3 17:17:42 LIBD[509]: HTTP<5+notice> response code: 302
Nov 3 17:17:42 LIBD[509]: HTTP<6+info > Content-Length: 0
Nov 3 17:17:42 LIBD[509]: HTTP<5+notice> redirect to new url
Nov 3 17:17:42 LIBD[509]: DCMN<3+error > BAD_PORT_NUMBER
Nov 3 17:17:42 LIBD[509]: HTTP<5+notice> response process finish!
Nov 3 17:17:42 LIBD[509]: HTTP<3+error > handler response error
Nov 3 17:17:42 LIBD[509]: DCMN<5+notice> Init config! libdownload Ver:5.3.0.9
Nov 3 17:17:42 LIBD[509]: DANY<0+emerg > LIBD log :sys=1,cons=1,time=0,E=3,W=4,N=5,I=6,D=7
Nov 3 17:17:42 LIBD[509]: DANY<0+emerg > DANY=7
Nov 3 17:17:42 LIBD[509]: HTTP<5+notice> URL : http://185.62.77.56/prov/y000000000025.cfg
Nov 3 17:17:42 LIBD[509]: DCMN<6+info > Connecting 1xx.62.77.56:80
Nov 3 17:17:42 LIBD[509]: DCMN<6+info > Connecting IP = 1xx.62.77.56, Port = 80
Nov 3 17:17:42 LIBD[509]: HTTP<6+info > Request Line: GET /prov/y000000000025.cfg HTTP/1.1^M
Nov 3 17:17:42 LIBD[509]: HTTP<6+info > Host: 1xx.62.77.56
Nov 3 17:17:42 LIBD[509]: HTTP<6+info > User-Agent: Yealink SIP-W52P 25.73.23.6 00:15:65:b1:62:82
Nov 3 17:17:42 LIBD[509]: HTTP<6+info > process response
Nov 3 17:17:42 LIBD[509]: HTTP<5+notice> response code: 404
Nov 3 17:17:42 LIBD[509]: HTTP<5+notice> response process finish!
Nov 3 17:17:42 LIBD[509]: HTTP<3+error > Client error
Nov 3 17:17:42 LIBD[509]: DCMN<5+notice> Init config! libdownload Ver:5.3.0.9
Nov 3 17:17:42 LIBD[509]: DANY<0+emerg > LIBD log :sys=1,cons=1,time=0,E=3,W=4,N=5,I=6,D=7
Nov 3 17:17:42 LIBD[509]: DANY<0+emerg > DANY=7
Nov 3 17:17:43 LIBD[509]: HTTP<5+notice> URL : http://185.62.77.56/prov/001565b16282.cfg
Nov 3 17:17:43 LIBD[509]: DCMN<6+info > Connecting 1xx.62.77.56:80
Nov 3 17:17:43 LIBD[509]: DCMN<6+info > Connecting IP = 1xx.62.77.56, Port = 80
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > Request Line: GET /prov/001565b16282.cfg HTTP/1.1^M
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > Host: 1xx.62.77.56
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > User-Agent: Yealink SIP-W52P 25.73.23.6 00:15:65:b1:62:82
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > process response
Nov 3 17:17:43 LIBD[509]: HTTP<5+notice> response code: 401
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > http auth type: 2,
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > Reconnect 1xx.62.77.56:80
Nov 3 17:17:43 LIBD[509]: DCMN<6+info > Connecting 1xx.62.77.56:80
Nov 3 17:17:43 LIBD[509]: DCMN<6+info > Connecting IP = 185.62.77.56, Port = 80
Nov 3 17:17:43 LIBD[509]: HTTP<5+notice> response code: 200
Nov 3 17:17:43 LIBD[509]: HTTP<6+info > Content-Length: 8440
Nov 3 17:17:43 LIBD[509]: HTTP<5+notice> response process finish!
Nov 3 17:17:45 ATP [533]: ANY <0+emerg > ATP log :sys=1,cons=1,time=0,E=3,W=4,N=5,I=6,D=7
Nov 3 17:17:45 ATP [533]: ANY <0+emerg > ANY =3
Nov 3 17:17:45 LIBD[533]: DANY<0+emerg > LIBD log :sys=1,cons=0,time=0,E=3,W=4,N=5,I=6,D=7
Nov 3 17:17:45 LIBD[533]: DANY<0+emerg > LIBD log :sys=1,cons=1,time=0,E=3,W=4,N=5,I=6,D=7
Nov 3 17:17:45 LIBD[533]: DANY<0+emerg > DANY=3
Nov 3 17:17:45 LIBD[533]: DCMN<3+error > getaddrinfo: Name or service not known
Nov 3 17:17:45 LIBD[533]: HTTP<3+error > Connect Error
Nov 3 17:17:45 ATP [533]: ATP <3+error > http to file failed, code = -1, msg = Wrong host, retry = 1

The RPS recognises the target server 1xx.62.77.58 but the subsequent dialogues seem to fail in several places. The RPS holds the credentials for the auto provision name and password. equivalent to
auto_provision.server.username
auto_provision.server.password

Chris
11-04-2016 12:20 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Michael_Yealink Offline
Administrator
*******

Posts: 46
Joined: Oct 2012
Reputation: 0
Post: #2
RE: w52P auto provision
hi Chris

thanks for you information

for this issue , have you try to configure RPS server URL together with user name and password and test again? it seems that the authorization is failed which caused the provision failed .

you can try configure below URL to your RPS account , server :

http://admin:admin@185.62.77.56/prov/

just replace the admin to the correct user name and password you use , then that would be OK for authorization .

please test and let me know if any update . if still not work , then it is advised to get the whole log file to us so that we can do some further analysis .

it is advised to use a wireshark tool to get the pcap file , for how to download the tool and use it , please refer to the link below :
http://forum.yealink.com/forum/showthread.php?tid=15529

for the syslog, please export it to server side , before phone reboot , you can refer to the guide download from below link :
http://forum.yealink.com/forum/showthread.php?tid=15529

for the config.bin file , please refer to the FAQ below :
http://forum.yealink.com/forum/showthread.php?tid=1319

after you collect all the three files, just send them to me ASAP

let me know if any question

TKS & BR

Michael
12-10-2016 08:18 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Michael_Yealink Offline
Administrator
*******

Posts: 46
Joined: Oct 2012
Reputation: 0
Post: #3
RE: w52P auto provision
hi Chris ,

any update ?

Michael
12-30-2016 07:47 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  DO NOT Provision / Update Firmware looker44 2 1,168 08-17-2021 04:44 AM
Last Post: looker44
  Step by Step for Auto Provisioning nguyenp 2 2,467 08-06-2021 04:27 PM
Last Post: Phil2021
  Auto-Provision W60P on FreeSWITCH Phoneperson 10 10,369 03-06-2021 03:51 AM
Last Post: Phoneperson
  Factory Reset via Provision Andrews1 3 5,687 07-02-2019 03:09 PM
Last Post: Fraukas2
  Auto provisioning seams to be (partly) broken in version 83 for T46G HaraldL 2 6,108 07-02-2019 03:04 PM
Last Post: Fraukas2
Lightbulb Auto provision firmware ... Yuriy Y. 1 4,446 04-26-2019 05:40 AM
Last Post: Yuriy Y.
  T22P always auto restart jamess2007 2 4,418 03-13-2019 11:49 AM
Last Post: Langveldt
  Firewall Settings for Auto Provisioning ChristophWHAT 2 6,775 02-04-2019 12:47 PM
Last Post: ChristophWHAT
  Auto Provisioning Hangs Rus 1 4,509 10-17-2018 11:06 AM
Last Post: Rus
  Auto provisioning file names shane.caznet 1 4,834 10-12-2018 02:56 PM
Last Post: jolouis

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication