[YMCS/YDMP Free Trial Program]Yealink would like to offer Free Trial Program of Yealink device management service for our current eligible customers. You can see the details below.
https://www.yealink.com/ydmp-freetrial-2020


Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XML InputScreen Problem on T19
Author Message
andrewmc Offline
Junior Member
**

Posts: 3
Joined: Nov 2016
Reputation: 0
Post: #1
XML InputScreen Problem on T19
Hello,

Can anyone explain why the following XML does not result in a HTTP_GET request with the appropriate query string when a number is submitted? Instead, the cursor on the phone freezes for a number of seconds before the phone returns to the home screen. The Apache log shows no HTTP request.

(I have had to convert XML tags to square brackets to allow this message to post)

[InputScreen type="number" cancelAction="http://192.168.n.n/beds/"]
[Title wrap="yes"]New patient]/Title]
[URL]http://192.168.n.n/beds/new_patient.php]/URL]
[InputField type="number"]
[Prompt]Patient ID[/Prompt]
[Parameter]patient_id[/Parameter]
[/InputField]
[/InputScreen]

Many thanks for your help.

Andrew
11-02-2016 11:48 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
andrewmc Offline
Junior Member
**

Posts: 3
Joined: Nov 2016
Reputation: 0
Post: #2
RE: XML InputScreen Problem on T19
I would really appreciate a response to the above question. Nothing I change makes this work -- and on a few occasions the phones reset when I submitted the field, rather than just freezing for 10s and returning to the main screen.

I have also tried the sample XML InputScreen from your web site and have the same problem.

I am on firmware31.72.23.1

Thanks,

Andrew
11-06-2016 04:52 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Yealink_Michael Offline
Administrator
*******

Posts: 382
Joined: Jul 2015
Reputation: 1
Post: #3
RE: XML InputScreen Problem on T19
hi Andrew

thanks for your information .

for this issue , do you mean that you use the XML browser and then the phone didn't responsible correct ?

1. you out the xml file to the server
2. set XML browser on a DSS Key
3. press the DSS Key , then phone didn't show the input screen ? or the phone didn't go to next step when you enter the correct number ?

please make the above question clear to me first , and then provide he XML file you used so that i can double check and test in my side .

BTW, i have see the firmware you use is for YUK , so have connect YUK team for a double check first ?

looking forward to your reply

Michael
11-21-2016 06:07 AM
Find all posts by this user    like0    dislike0 Quote this message in a reply
andrewmc Offline
Junior Member
**

Posts: 3
Joined: Nov 2016
Reputation: 0
Post: #4
RE: XML InputScreen Problem on T19
Dear Michael,

Yes, I mean the phone did not respond correctly. When I try to submit text, the screen freezes and after a few seconds returns to the home page.

I will post the XML file as an attachment when I am on my main computer. But it is essentially what I included in the first post.

Also, the TextInput sample from Yealink doesn't work.

Thanks,

Andrew

(11-21-2016 06:07 AM)Yealink_Michael Wrote:  hi Andrew

thanks for your information .

for this issue , do you mean that you use the XML browser and then the phone didn't responsible correct ?

1. you out the xml file to the server
2. set XML browser on a DSS Key
3. press the DSS Key , then phone didn't show the input screen ? or the phone didn't go to next step when you enter the correct number ?

please make the above question clear to me first , and then provide he XML file you used so that i can double check and test in my side .

BTW, i have see the firmware you use is for YUK , so have connect YUK team for a double check first ?

looking forward to your reply

Michael
11-23-2016 04:14 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Michael_Yealink Offline
Administrator
*******

Posts: 46
Joined: Oct 2012
Reputation: 0
Post: #5
RE: XML InputScreen Problem on T19
hi Andrew

hope you have a nice holiday .

for this issue , still not received your reply , please attached your xml file so that i can double check again .

at the same time , i have attached the guide and template which i test can work here

looking forward to your reply .

Michael


Attached File(s)
.pdf  s_Guide_V72_1.pdf (Size: 2.12 MB / Downloads: 1)
.xml  TextMenu.xml (Size: 1.72 KB / Downloads: 1)
12-30-2016 03:55 PM
Find all posts by this user    like0    dislike0 Quote this message in a reply
Post Reply 


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
Question Problem with forwarding call after no answer - SIP-T26P / SIP-T27P Yves 1 4,838 12-30-2016 06:52 AM
Last Post: Travis_Yealink
  T20 and T21p registration problem raltel 3 5,192 12-30-2016 06:01 AM
Last Post: Lucia_Yealink
  T21 E2 Transfer problem ruben85 1 3,298 05-10-2016 06:49 AM
Last Post: Yealink_Michael
  t46g sound quality problem vs t20 asinshesq 16 35,671 02-05-2016 05:01 AM
Last Post: Bryan
  T48G Call-Transfer Problem robtrop 2 4,762 07-29-2015 05:58 AM
Last Post: robtrop
  Picking up second call Problem LARRYFRANK20 4 7,976 12-06-2014 09:24 AM
Last Post: Yealink_Jim
  Call Waiting Tone Problem T46G LARRYFRANK20 3 8,023 12-05-2014 07:04 AM
Last Post: CWR
  T46G sound problem, interruptions cargotrans 5 9,201 12-02-2014 04:05 PM
Last Post: James_Yealink
  T46G media negotiation problem f.ammollo 1 3,706 08-19-2014 02:51 PM
Last Post: Yealink Support

Forum Jump:


User(s) browsing this thread: 1 Guest(s)

Contact Us   Yealink   Return to Top   Return to Content   Lite (Archive) Mode   RSS Syndication